RZBOX unable to install Windows or Linux

I am unable to install any OS on the RZBOX I received today. Windows 10 crashes with Error Code"0x80070001" at anywhere from 6% to 26% when installing. Ubuntu Linux will have an installer crash after it finishes copying files.

I have tried with varying sets of RAM and SSD

Samsung 960 Pro 512GB SSD

2x 32GB 2666Mhz RAM
2x 4 GB 2666Mhz RAM

I have tried multiple USB drives with no success.

I even tried installing windows on another PC and moving the SSD to the RZBOX after. Windows Froze instead of booting.

Is there a way to fix this?

i have the same issue just a different error code.

I did more digging and found that any SSD i used would disappear from the system a few seconds after writing to it. mkfs.ext4 basically gets to writing superblock information and the dies with the SSD no longer being present to the system.

Not sure if this is a BIOS configuration issue or I have a bad unit. All of the SSD’s i tried test just fine in other systems.

I decided to try the SATA m.2 I have in my larkbox. SATA m.2 drive work fine but not NVME. Going out to buy a couple of 1TB Samsung 860 M.2 2280 SSDs so I can use my RZBOX. I have a feeling that Chuwi only tested with the NVME they ship with the RZBOX.