RZBox doesn't like High Speed NVME drives

When I originally got my RZBOX I used Higher speed NVME SSD 2900 Read / 2100 Write. Every time I attempted to install Windows or Linux the install would freeze or the SSD would vanish from /dev on linux.

Eventually I tried SATA M.2 Drives and those worked but were slow.

Finally I had bought one of the slower NVME SSDs that had a 2400 Read and 1600Write and decided to try those. To my surprise those worked.

There is something with the RZBOX that causes it to freeze when using higher speed NVME drives.

Note all NVME drives were PCIe 3.0 and were from different manufacturers.

CHUWI,

I would respectfully recommend that you put together a list of NVME SSDs that are known to work with the RZBOX at the minimum. It will save customers from trying an SSD that will not work in the RZBOX. If it is possible to release a BIOS update to remedy the issue it would make the RZBOX an even better product.

6 Likes

Yes this is a right request !

I am also seeing problems with High Speed SSDs installed in a RZBox. I purchased two Intel 1 TB Series 670p drives and first tried to copy the Windows 10 Home from the original SSD to an Intel 670p using Macrium Reflect, that failed twice, I then tried to install Windows 10 on the 1TB drive and got a WHEA_UNCORRECTABLE_ERROR message at random times once the new install of Windows booted and I was copying files. I tried to mirror two of the 670p drives and that failed as well, finally I decided to just keep the original Kingston drive with Windows 10 installed by CHUWI and add one Intel SSD. That failed as well as when I went to format the drive, it failed at 9% and got a message that the drive was unavailable. I agree that a BIOS update is needed to handle higher speed SSDs.