Single Boot on my Hi10X

hi,
is possible to install android and windows 10 in my Hi10X?
serial is Q128G20010807, thank’s all

1 Like

I installed android x86 8.1r3
Everything work except orientation sensor not working
Also due to touch screen not working at bios level keyboard is needed to select OS

I wonder why touch not working in bios setting while as AMI site touch is supported in aptio v bios

Same here. I was able to install Android x86 version 9 but its stuck in portrait orientation.

I’d love to get the orientation sensor working.

  1. I installed Android x86 9.0 r1 on an usb-c Key

    • ext4 formatted (GPT) usb-c Key.
    • Instal EFI grub2
    • /system R/W : yes (to be able to tweak it)
      *EDIT : need keyboard to start android as windows is set by default. dunno if there is a way to control grub via volume buttons and windows key
  2. screen Orientation (half-fix) ,

  • you need to modify /system/etc/init.sh

  • there is a line in

function init_hal_sensors() { [...] *) has_sensors=false

  • you need to change false by true
  • chmod 744 init.sh
  • reboot
  • apps like rotation control should work properly now. (they can be found on apk mirror)
  1. keyboard work properly, touch keyboard doesn’t show up so force it in settings> languages…

  2. Stylus work somehow but no pressure and not really recognized as one.

I’d like to get the stylus working, if you guys have any clue, I’d be glad to hear

I’ve got android working quite well with that orientation fix mentioned above with Android x86. If really love to have auto rotate to work. I guess we just need to put the correct driver info into init.sh but I’ve got no idea how to know where to find that info. In Linux installing iio-sensors-proxy doesn’t work soon obviously it’s not the generic iio driver most systems use.

I’m having issues with power. Does anyone have an idea how to get a single tap of the power button to make android sleep? Currently a tap of the power button brings up the power menu with options to power off or reboot. To sleep I have to hold the power button down for 1-2 seconds.

android x86 9.0 r1 . I’ve the sleep option in the powermenu button.

I dunno how close hi10X is to hi13 because in some posts on the web, the hi13 with older android x86 (presumably 7.1 ) is “fully” working out-of-the-box sensors, touchscreen etc(no information about hipen h3 stylus support tho)

I think the Hi10X is closer to the UBook with the N4100 celeron processor.

Anyway, I’ve given up on Android, it’s not working the way I want so I’ve tried to go back the Windows. The problem is the official Windows image provided above is corrupted when I try to install it. It gets to about 16% and says it can’t go any further. I check the logs and it’s due to corrupted files within the windows install.

Has anyone else tried to reinstall windows with success?


Did you download it from this link?If not, please try this again.If you have any questions, please continue to @ me.

Hi all,
I had some success. I managed to get windows installed, no thanks to Chuwi.

I downloaded the official windows iso using the creation tool from Microsoft. I created 2 copies: 1 on a USB stick, the other on a micro SD card. The Hi10X won’t boot from sd card for some reason so this is why you need the windows USB stick. When windows setup starts it complains about a lack of drivers if you only have the USB stick because I guess for some reason there’s a problem with the windows install reading from the USB ports on the Hi10X. This is why you need the SD card. Once the windows install starts you can take the USB stick out because the install needs to reboot to continue so to avoid rebooting into step 1 of the install process take out the USB before the first reboot.
Once the reboot happens setup will continue as normal.
Once windows is installed you need to install all the drivers. Search these forums for advice on that.

Chuwi - why do you make this so complicated?

It didn’t work. I had the same dism error.

I think Chuwi needs to find an alternative to sharing files on MediaFire. It seems the rar splitting process is corrupting files.

Just use the normal windows install iso and add the drivers. Then share the new iso on a website that allows 4Gb files that people can download and use a program like Rufus to burn the iso to a USB disk.

Also why can’t windows detect the USB drive when using the official Microsoft install disk? Most fixes out there just tell people to swap from a USB 3 drive to a USB 2 one.

How to install Android?

How to modify init.sh? When i change false to true appear an error and than i can’t save

when you install you need to check the option for writable system partition otherwise you cannot modify it.

Where i check the option?


it’s in the install process , otherwise the system partition is a read-only image

you should read the manual https://www.android-x86.org/installhowto.html

Hi…nklh I follow for your recommended but i have 3 question for ask you because I don’t understand.
1."screen Orientation (half-fix) ,

** you need to modify /system/etc/init.sh*
** there is a line in*

function init_hal_sensors() { [...] *) has_sensors=false

** you need to change false by true"*

But I can’t find that line in init.sh I found this only

*"function init_hal_sensors()
{
# if we have sensor module for our hardware, use it
ro_hardware=(getprop ro.hardware) [ -f /system/lib/hw/sensors.{ro_hardware}.so ] && return 0

local hal_sensors=kbd
local has_sensors=true
case "$UEVENT" in
	*Lucid-MWE*)
		set_property ro.ignore_atkbd 1
		hal_sensors=hdaps
		;;
	*ICONIA*W5*)
		hal_sensors=w500
		;;
	*S10-3t*)
		hal_sensors=s103t
		;;
	*Inagua*)
		#setkeycodes 0x62 29
		#setkeycodes 0x74 56
		set_property ro.ignore_atkbd 1
		set_property hal.sensors.kbd.type 2
		;;
	*TEGA*|*2010:svnIntel:*)
		set_property ro.ignore_atkbd 1
		set_property hal.sensors.kbd.type 1
		io_switch 0x0 0x1
		setkeycodes 0x6d 125
		;;
	*DLI*)
		set_property ro.ignore_atkbd 1
		set_property hal.sensors.kbd.type 1
		setkeycodes 0x64 1
		setkeycodes 0x65 172
		setkeycodes 0x66 120
		setkeycodes 0x67 116
		setkeycodes 0x68 114
		setkeycodes 0x69 115
		setkeycodes 0x6c 114
		setkeycodes 0x6d 115
		;;
	*tx2*)
		setkeycodes 0xb1 138
		setkeycodes 0x8a 152
		set_property hal.sensors.kbd.type 6
		set_property poweroff.doubleclick 0
		set_property qemu.hw.mainkeys 1
		;;
	*MS-N0E1*)
		set_property ro.ignore_atkbd 1
		set_property poweroff.doubleclick 0
		setkeycodes 0xa5 125
		setkeycodes 0xa7 1
		setkeycodes 0xe3 142
		;;
	*Aspire1*25*)
		modprobe lis3lv02d_i2c
		echo -n "enabled" > /sys/class/thermal/thermal_zone0/mode
		;;
	*ThinkPad*Tablet*)
		modprobe hdaps
		hal_sensors=hdaps
		;;
	*LINX1010B*)
		set_property ro.iio.accel.x.opt_scale -1
		set_property ro.iio.accel.z.opt_scale -1
		;;
	*i7-WN*)
		set_property ro.iio.accel.quirks no-trig
		;&
	*i7Stylus*)
		set_property ro.iio.accel.x.opt_scale -1
		;;
	*LenovoMIIX320*|*ONDATablet*)
		set_property ro.iio.accel.order 102
		set_property ro.iio.accel.x.opt_scale -1
		set_property ro.iio.accel.y.opt_scale -1
		;;
	*SP111-33*)
		set_property ro.iio.accel.quirks no-trig
		;&
	*ST70416-6*)
		set_property ro.iio.accel.order 102
		;;
	*e-tabPro*|*pnEZpad*|*TECLAST:rntPAD*)
		set_property ro.iio.accel.quirks no-trig
		;&
	*T*0*TA*|*M80TA*)
		set_property ro.iio.accel.y.opt_scale -1
		;;
	*)
		has_sensors=False  **<== I'm not sure this line is correct or not**
		;;
esac

# has iio sensor-hub?
if [ -n "`ls /sys/bus/iio/devices/iio:device* 2> /dev/null`" ]; then
	busybox chown -R 1000.1000 /sys/bus/iio/devices/iio:device*/
	[ -n "`ls /sys/bus/iio/devices/iio:device*/in_accel_x_raw 2> /dev/null`" ] && has_sensors=true
	hal_sensors=iio
elif lsmod | grep -q lis3lv02d_i2c; then
	hal_sensors=hdaps
	has_sensors=true
elif [ "$hal_sensors" != "kbd" ]; then
	has_sensors=true
fi

set_property ro.hardware.sensors $hal_sensors
set_property config.override_forced_orient ${HAS_SENSORS:-$has_sensors}

}
"*

Question Where the line for change false by true?

2.“chmod 744 init.sh” it most important or not, if it important pls let me know how to chmod 744 with ???

3.I try to guess to edit has_sensors=False => True ,and reboot. After that install “Rotation Control” from “Google Play”. I’m not sure it correct or not , it not automatic rotation but if I choose “Forced landscape” it can be use on landscape mode.

4.If I want to rool back to use windows only or uninstall android from my table how can uninstall android?

Regards,

it’s exactly this one the point is forcing the “has_sensors” variable to “True” otherwise in landscape it’s all messed up and it’s only this the workaround fix somehow .
but there is no driver for sensors so you can manually switch the screen orientation and automatic rotation is out of reach so far.

as for chmod 744 frankly I do not remember, overall, files in android systems folders often require specific permission to be set. dunno why I had to reset this to 744 .
you basically type in shell terminal :

chmod 744 nameOfTheFile

in this case would be chmod 744 init.sh (assuming you are in the right folder)

Thanks for the rotation fix… Worked with rotation control from the app store and Android 8.1r5 for me… Except for touch does not work until I let the tablet go to sleep and wake it up after booting. 9.0r2 always crashes for me…

Would be awesome to get touch support for uefi so we can dual boot without a keyboard. Im using rEFInd 0.12 and it doesn’t detect touch

Solve the Android x86 screen rotation issue on the Chuwi Hi10x device