The microphone and speaker are disabled when the screen is locked during a mobile call via a SIM card or WhatsApp

Hello. I have a HiPad Xpro on Android 13, I bought it not long ago. No changes were made to the system, a clean system out of the box. The tablet cannot be used in any way when the screen is locked. How does this manifest itself in practice? For example, someone calls me on the SIM card installed in the tablet, I answer, while the screen is active everything works and both people hear each other, but if you lock the screen yourself or it locks itself after a while, then the microphone and speaker on the tablet completely stop working . That is, when the screen is locked, I can’t hear the interlocutor and he can’t hear me, as soon as I unlock the screen everything works fine again, the call does not end when the screen is locked, only the microphone and speaker stop working. Same thing on WhatsApp. One interesting thing is that if I press the volume up/down button during a call with the screen locked and the microphone and speaker not working, the other person starts to hear me and I hear him for exactly 3 seconds, then the sound disappears again and the microphone turns off. In general, the tablet is impossible to use. The Phone app and WhatsApp have been updated to the latest version. Power saving mode is turned off, all application permissions are granted and nothing is disabled.
Added: I tried clearing google services data, I tried a full reset of all data. It doesn’t help. When I reboot the device, sometimes the first received call works normally with the locked screen, but if you make the second one, the problem reappears.
SN: CHipXpEB10231001475 (Aliexpress)
FW: T616_P30_CHUWI_HiPad_XPro_EEA13_20230921_20230921-2142

As it was bought in Aliexpress, you need to contact the Aliexpress store, because in case it needs to be sent to be repaired, it is them who need to process that. So its better they have all the information from beginning. I am sure they will help you fast.

I have already read here on the forum how people send parcels back to China and they get neither money nor the tablet back. Sending it back would cost me probably half the price of the tablet. So I’m gonna hold off on that for now. You still don’t think it’s a firmware problem? I wrote that sometimes when I reboot and make the first call everything works fine, then it stops working again.

If you are ok with it, i can send you the firmaware that came with the tablet to see if it would solve it.
But if you did not touch anything, for trying we dont loose anything.

I certainly doubt very much that a normal reinstall will change anything, it’s more likely some sort of fix/update is needed. Here I’ve already tried another calling app - same problem with it. The most interesting thing is that the voice recorder records and plays back with the screen locked fine and without problems. And the warranty is lost, as I understand it, right? I wanted to find the firmware myself, but your site doesn’t work at all and gives a database error (

If you send me your serial number i can find the files for you

So he’s listed in the first post…
SN: CHipXpEB10231001475

You can make a backup first of that firmware.

Try installing this one:

Tutorial + Flashtool:

There are no drivers in your archives. Also there are no instructions for a full backup of the current tablet firmware (without userdata).

@manonegra can you tell how to make a backup?

I installed this firmware and the problem did not go away.
Another observation - I flashed the firmware, immediately added a google account and updated all apps and started checking calls. The first 3 calls (1-2 minutes each) went without problems, with the screen locked everything was audible and the sound from the speakers was not lost. Then I left the tablet for 10 minutes, then I called it again and the problem appeared again. Anyway, no matter how I try it, nothing works. One time it even happened that the speakers turned off during one of the test calls even with the screen on. Now it’s back to not working again, just as I described in the first post of this thread.

Det finns ett litet hål bredvid volym knappen i ett hål brevid stick in en liten nål ej vass i båten i hålet så ska plattan starta om vid start Mvh Åke.

Then it may be a hardware problem. Is the device still on warranty? so you can send it to repair it?