SD card reader does not work. Any Fix for this?

I have a Hi10 pro 2in 1 (dual boot). It originally came with Win 10 and Remix 2.0. From the beginning I have encountered problems with the SD card reader. It does not appear to be an issue with the brand,size or speed of the card itself. Formatting does not appear to be the cause; FAT, FAT32, exFAT all have issues. Having tried multiple brands with speeds from class 10 to 3 Ultra and 8 to 64Gb, the result is the same. Every card I have tried works flawlessly in my phone or other devices. In Remix (android) the card isn’t even detected most of the times it is inserted. 9 of the 10 times it is detected it will say the card is damaged or corrupt. Every so often (if left inserted) the SD card will appear after a boot up and work. If I’m lucky I can actually read/write from it for a while before I eventually get a message the card is corrupt. The same card(s) seem to work slightly better in Windows 10 but still not reliably. It will often say the card needs to be formated.

I have grown tired of remix and its lack of support. Therefore I decided to flash the rom from Remix to Android 5.1 (I kept the dual boot and Windows 10). The hope was this would fix some of the crashing I experience with Remix and I was really hoping the SD card issue would be fixed with a different OS. Well the OS seems stable but the SD card issue wasn’t fixed. The new OS doesn’t seem to recognize SD cards at all.

After doing some research it appears this might be an issue in the BIOS. Is there any fix other than a BIOS update? If not is there a bios update for a serial number PQ64G421609006XX. The only BIOS updates I have found are for serial numbers starting with HQ64

Thanks in advance,
Lonnie

1 Like

Salve, ho lo stesso problema con la scheda SDcard che non viene letta. Si può risolvere senza reinstallare tutto?

Può funzionare con qualche regolazione o impostazione dal BIOS? Sarebbe possibile avere la guida sul come entrarci nel BIOS? Grazie

No, there are no updates of Bios, since the later ones that you see, correspond to other models of the same tablet and the flashing with these Bios can produce brick. American Megatrans, manufacturer of the Bios, did not develop new Bios that corrected this problem.
The problem of the SD reader is known and is produced by the difference in behavior between the two systems of said reader. This makes it not recognized, first in one and finally in the second system. My advice is that you do not use the shortcuts from one system to another but turn off the tablet completely before starting the other system.
The only proven solution, although it does not prevent it from happening again, is that, after a few days using the tablet normally on both systems, without having an SD card in the slot, start the tablet normally but with a pendrive (the content does not matter of this pendrive) placed in one of the ports, either of the tablet itself or of the keyboard. After this, insert the SD card and almost certainly, it will be recognized.
I have verified that there are some cards that frequently give the error and others, among which is Sandisk, which occurs less frequently.

Do not touch the Bios

No, it will not solve the problem. Try what I wrote above