Ubuntu on Corebook X

Hi, I have just bought my new Corebook X and I’m trying to install Ubuntu with dual boot, but I always have the same error when the copy file is ending. Errno5 intput/output error. I’ve tried two different usb flash drive and two versions of Ubuntu, 20.04.3. LTS and 21.10.
Has anybody any solution?

@spikerguy I’ve seen you know a lot about linux, may be you can help me?

This one is saying that disk is having problem.

While second one I cannot understand as its a foreign language for me.

Most likely the windows partition is not allowingn the installer to shrink the drive and create a new partition.
You should try to shrink the drive manually and then install fresh ubuntu on the empty partition.

I forgot to say that when checking files before instalation it sais 1 error but It continues and I dont know why because its a new laptop. Also, I’ve done a partition of 175gb on windows and then at the installation process I give 30 gb for ext 4 / , 8gb for swap and the rest for ext 4 /home. Is that what you mean?

Ok I have just solve it!! What worked for me was using this command in CMD as administrator to check disk files.
chkdsk c: /f /r
Hope helps someone with the same error.

1 Like

I have been trying to convince chuwi to sell some of their hardware with Linux pre-installed but they’re not so interested in this idea.

The first partition(EFI) is allocated 100MB initially. This might be too small for dual/triple boot. When I make triple boot system in Chuwi Ubook pro, Linux(Solus)/Android(Phoenix)/Windows10, I allocated 1GB for EFI partition. You’d better do partitioning again.