Vi8 Plus Corrupted Bios

Hello there. I have a problem with my bricked Vi8 Plus with corrupted bios which doesn’t boot up or charge.
I’ve learned that I need the right Bios file corresponding my device. The serial number is VI8 P32G22151202606

Hello,
The forum will no longer provide the customer with BIOS.
If necessary, please describe the reason for the need for BIOS (or describe the device problem) and send an email to aftersale@chuwi.com for processing.

1 Like

I didn’t notice the announcement regarding that issue at first. My apologies. I’ve sent the email and now waiting on response.

If more than 48 hours have elapsed (not counting the weekend) and you have not received an answer, write here and we will try to answer you as soon as possible

1 Like

I’ve gotten a response from aftersale-service@chuwi.com but they’ve actually given me the same link for the Bios from this topic [Vi8 Plus] [Official Version][Singleboot] Chuwi Vi8 Plus Windows 10, Bios, Driver Download

The thing is I’ve already tried flashing that bios onto my device and it still won’t boot up. I’ve even tried flashing bios from the dualboot series - nothing.

I’m using a CH341A progammer with 1.8v adapter to flash the bios chip. The device’s battery is also intact as I’ve charged it with an external charger. I’m clueless of what to do. Is there any other particular bios for that model with my serial number?

Please, may I have the correct file or something that should help me unbrick my device?

Try this BIOS and let me know when you’re done

Unfortunately flashing that bios didn’t revive it either. Still no booting up or charging. Not exactly sure what is wrong now :frowning_face:

What caused bios damage? I mean, are you sure that the bios is 100% damaged? Recently I bought a broken hi10 pro, the service tried to flash the bios, but they did not even pay attention to the voltage on the board, processor was in a short circuit.

The chip gets read and verified perfectly so I’m not 100% sure if the bios is the problem. Basically what I did was that I changed some wrong bios settings related to my tablet’s RAM cause it was acting up and it wouldn’t boot anymore after I saved them and rebooted my device.

I sort of gave up by now cause there is not much I can do other than reset the bios chip.
I’m grateful to all of the Chuwi support staff for trying to help me though.