Wake on WoWLAN (or WoLAN)

Have any of tried the Wake on Wireless LAN or Wake on LAN with the Herobox Pro?

I have configured everything but I could not make it work on Linux.

Thank you,

I’m also looking for this. I have tested windows 11 and it only worked once on a magic packet.
Ao it looks like it must be posible… I’m currently trying to make it work using fedora linux.

I enabled Wake On Lan in the bios.
and looking in my router the herobox has a IP adres

did you try wake on lan or also wake on wireless lan? Thank you!

Only Wake On Lan, using the gigabit ethernet controller I225-V.
(It seems the WLAN module is powered off completely and their is no setting in the bios for this, so I assume this is not possible)
Wake On Lan does not seem to work with the current bios but it should be possible the option is there, a bios update by Chuwi could fix this issue, it would be a great feature to have this working and makes it absolutely perfect for a small home server.
Which bios version do you have (I have GB3B102)? Press ESC while booting to enter the bios. to view some additional setting is the bios you can use the alt+f5 key.
The network stack should be active while in bios and power down state. I removed the DHCP lease for my heroBox (when it was powered of and disconnected from power). reapplied power ethernet status LED turns on on the router but no IP-address gets assigned.
after turning on and entering the BIOS still no IP gets assigned.
only when the system is booted in an OS fedora or Windows an IP address gets assigned. It seems the problem is in the bios firmware.

could you verify something for me? I have a additional problem, when I force a shutdown by holding the power button for >~5 sec the device turns off as expected but I’m not able to turn it back on using the power button only by removing the DC power supply. (I would like to know if this behavior is only on my device or also a problem with the BIOS)

I did some searching and found this is a known problem (J4125 processor and the I225 ethernet controller).
I found some information about this problem that might be useful for implementing the BIOS fix:

I contacted Chuwi Support about this problem, currently there is no fix available yet.
I hope they can provide a bios update soon.