Best Android image for dual boot

So what I understand from all the posts here is that BlissOS is the best installation if you want proper dual boot?

I think I read everything works? I mainly will use for net browsing, watching videos, and ebooks (kindle reader, moon book pro, Google books). I want that I can easily sleep it with pressing the power button, and wake it again that way… In seconds.

It will replace my Samsung note pro 12.2.

Just received the Ubook Pro. took just 9 days to receive it. Impressed with banggood. For me having Android on it is essential! Windows 10 is practically useless in tablet mode.

I will journal what all I am trying to get it working as an Android tablet. I will only experiment booting via USB until I find one that works (works as defined in my OP).

I update windows 10 fully with all the latest drivers, patches, etc.

Initial test: connect with wifi, open brave browser, load up youtube and music video Claydee-Alena in 2160 resolution; but also 1080p will be ok. Any lower is not ok. Then mid-way connect to my bluetooth speakers and keep play the music video

Initially, I will have the keyboard attached.

Today I tried Bliss OS 12.8 - full experimental version, in following formats:

  • Live or legacy modprobe mode: Totally useless. Just trying to bring down the taskbar to connect to wifi crashes the System UI. I was lucky to be after 10 minutes of trying able to reboot the tablet (I guess I could have long-pressed the power button to force shutdown). Tried 2-3 times. Same result again and again - can’t even bring up the wifi settings. As soon as I touch the touchscreen it crashes the System UI
  • with Vulcan support - got the furthest with this. Even then it was not a good test. First tried with 2160 (looked stunning video! I had heart filled smile with the res) - was playing fine until I tried to minimise the video and connect to bluetooth. Crashed the display - it was just hung and not accepting any input, music stopped playing.
    I restarted and then tried 1440 - same outcome as 2160.
    I restarted and then tried 1080p - got further and was actually able to connect to bluetooth while song was played and video minimised to the side. But eventually it hung too

More tests later. If anyone has had more luck then let me know. Idea is to test next with a bit more on Bliss OS 12.8 (experimental), then go to experimental lite, and then stable version. Then also test PrimeOS. This will take about 2-3 days I think. Then I will settle with one most stable one so far and use that for a week before installing it to the hdd and making it the primary booting OS as I cannot see myself ever using Windows 10.

BTW, it is all very ZIPPY/fast. It has been a pleasure to use, while it is working. I wish Chuwi would invest some time in creating some Android instructions -> their sales would quadriple. There is a much bigger market of people wanting to use this as an android tablet or 2-in-1 Android/Windows tablet than a windows only tablet. I think there are some legal reasons that Chuwi haven’t done this - I would guess Microsoft are not allowing it! (think I read Google also doesn’t allow it but I am sure Chuwi can find a way around it … secretly leaking the info :wink:

Now tried BlissOS 11.11 and was surprised by the results. The only overall thing I want to say is that 12.8 (experimental) looked a lot slicker, modern, sharper, better colors

  • Live version: absolutely did not work in the sense that touch screen did not work. If I used keyboard and trackpad then it was fine
  • Vulkan - was surprised that this did not work at all! This version was the ‘best’ for v12.8 (but still well short of acceptable)
  • debug mode - worked the best but I think you have to keep typing in ‘exist’ a few times to go through the boot process. Even in 2160 resolution the tablet was managing. There was a lot of lag and buffering (even if I went to the start of the song and I know that youtube had d/loaded that part of the song). Eventually Chrome crashed. But the tablet itself didn’t crash and was responsive throughout.
  • Legacy Modprobe mode- this also worked well, but I would say debug mode was the best but I would go with Modprobe I think because there is no reason to type ‘exit’. If I remember correctly Modprobe in 12.8 was useless, so I will re-check that because my strong desire is to have 12.8 working because that looks really good!

Keep in mind that I am not installing the OS nor signing into play store yet, so maybe some drivers/libraries are missing. Screencast didn’t work for any of the 11.11 versions

Assessing so far, I would probably go back to 12.8 and try and see if I can get that to work somehow by updating libraries, modprobe mode, etc. Anyway, next will be the Experimental Lite version.

tried bliss os lite - Live, debug, modprobe - total failure. Sound didn’t work in any of them! And generally they all crashed (the OS) when I tried to connect to bluetooth

PrimeOS (0.4.5) - standard and classic - looked really slick and stable. But wifi would not turn on so that was a deal breaker. I tried live and debug
PrimeOS (0.4.5) - mainline - everything worked but touchscreen wouldnt work. LOL - you can’t make this stuff up! Are they doing this on purpose? How is that for classic wifi doesnt work but touchscreen works; and for mainline wifi works but touchscreen doesnt :frowning:

1 Like

so looks like for now I am going to go for Bliss OS 12.8 with Vulkan support. As long as I don’t try and connect with bluetooth at the same time as I am playing audio it seems stable enough to give it a proper shot …

I was looking at installing cloudready chrome os but decided against it for now

I just can recommend this one

Dual boot win 10 and chrome os, installed via Linux mint.

All works like a charm. All driver works, no Problem at all. Using it now like 3 month without any problems.

Chrome os is also Android with Google Play support


Does is support autorotate? :slight_smile:

thanks for the idea for ChromeOS - I read your post a while back in another thread but was trying to avoid.

Now I thought … why not? if it is stable

however, your instructions I think will not allow for dual boot Windows 10 and Chrome OS. And also that image in the video is for v80 and now v84 is out

I have found some instruction on how to dual boot so will try that. Thanks for the idea and appreciate your post

I have successfully installed Chrome OS (v84) and multi-booting with Windows 10. The Chrome OS is in a 100gb partition as I plan to use that mainly.

Man sooo stable. I ran the music video on 4k and it ran easily, and it was d/loading 4 other things, while I was also changing settings and connecting to bluetooth. Smooth like butter!

Auto-rotation is not working. Have to do it manually.

Now have to see how long power lasts, and if all my android apps work or not. Very happy at this moment in time - display looks stunning! :wink:

this video is just to show you “how to” of course i also installed latest one.
chrome os is so stable, its ridiculous. to be honest i deleted my windows partition. all apps or programms i work with are aviable for android.

how do you do auto rotate manually? no need rotation, but its good to know how.

yeah 4k streaming and multitasking is not a problem anymore.

“EDIT: manual rotation in settings, saw it. thanks anyways :)”

Hi where do I download the latest Chrome OS? v84? :slight_smile:

Also, how do I rotate my Ubook from landscape to portrait? Does your stylus works on chromebook?

Hi DonKing, I followed this and I installed Chrome OS, it worked smoothly. I really appreciate you for sharing this stuff. :blush:

But I have accidentally deleted my windows 10 os. :frowning: I have skip the disable the sata for I can’t see my ssd drive, it is a lot different in the video. :sweat_smile::sweat_smile::sweat_smile: Will find out how will I install Windows10 again. Do you have any idea? :sweat_smile:

You can just download an app from play store that allows you to rotate the screen. Or you can go into swinger and choose the orientation

1 Like

Did you tried to dual boot your Ubook with single drive?

Yes single physical hard drive - multiple logical partitions

There are some niggles - like wake up from power save in ChromeOS is not good sometimes if left for long time (have to restart), boot manager is a bit fiddly. I haven’t had time to look into them but ok to live with them, for now. Maybe in the future I might make it a ChromeOS only tablet as I don’t really have need for Windows 10 in it if I have these hassles

How did you make it work? I can’t disable my ssd. Also, I’m having trouble with my Boot menu I reinstalled the Windows 10 but the fn + f7 doesn’t work.

disable SSD? I don’t think you should be disabling any SSD -> where did you get the instructions you are following? The youtube posted by DonKing is not for use with systems with single HDD

so if you follow those instructions for the Chuwi Ubook Pro it will delete your windows 10 partition at worst, and it just won’t install at best

So now you restored your windows 10 and have your system back?

Yes. I followed DonKing shared link. And lost my Windows 10. But I have restored my Windows 10 already. Can you share us how you successfully install dual boot Chrome OS?

I think someone already gave you the youtube video of how to do dual boot.

It has been a while, but these are the instructions I followed, it also tells you how to get the latest chromeOS (v83 when I installed I think)

I think if you follow this you should be good to go. Some pointers:

  • you don’t need to create two partitions and do all that convoluted steps of creating a 100gb, and 60gb partition. Just one partition will do … anything 60gb+ should be fine
  • at the end of the ChromeOS you will get some errors like " “ failed-to-get-canonical-path-of-cow" - I just ignored it
  • after you reboot after above you will get back into windows 10 and start to install grub2win. I could not get grub2win to become the boot manager permanently (there are some discussions about this in the youtube video someone replied to you in other thread). After I have made the entry for ‘ChromeOS’ in grub2win and saved/applied those change, what I have been doing is clicking on ‘Set EFI Boot order’ and then in the next screen there is option to choose ‘do one time test’ or something like that. Then saving all that and rebooting -> then you will see the grub2win boot manager come up. You can pick ‘Chrome Os’ in that and it will boot into ChromeOS. But when you reboot again it will go back to windows 10 next time, and again you will have to do ‘one time test’ to get the grub2win boot manager to come up. I haven’t spent time trying to figure out why grub2win remains the boot manager - if you do then let me know.

The other thing, as I have mentioned, if you leave ChromeOS in sleep for a long time it then basically ‘turns-off’ and once again you have to do the ‘one time test’ to get back into grub2win menu.

If you get stuck with something let me know - maybe I missed to tell you some of the other traps I got caught in and had to figure out .

1 Like