UBook Pro Dual Boot Installation Failure

I’m having an issue trying to install any Linux-based OS on the UBook Pro. As a note, I’ve also owned a Lapbook Plus and Lapbook Pro, so I’m familiar with the fact that getting Linux to install can be an issue. I am NOT having the problem with the single underscore causing a failure to boot. I’m aware that means that the boot from the USB failed to initialize.

Instead, the issue is that I get to a grub-like page usually to do the install, but then the install fails before I even get to the UI to select options such as partitioning, formatting, etc. I have tried to install Deepin, Zorin OS, and Ubuntu, all without success. I tried the last 2 OSes because they boast universal support, so I’m shocked that this failure has happened.

I wasn’t able to take screenshots, but I took pictures on my phone of what happens with the Deepin installation. It basically keeps pasting everything between the “Timeout waiting for hardware cmd interrupt” over and over again every few seconds until the machine suddenly powers off. I know that some of these come pre-loaded with Linux, so a dual boot should indeed be possible. Anyone have any ideas on how to make it happen? Deepin is my most preferred distro btw, so if it has to be distro-specific in the solution, deepin is the one haha.

I uploaded the files to imgur since I took them on the phone but am using the UBook Pro to type this message. The images can be found here:

Anyone have any ideas?

I installed Linux Mint 19.3 dual boot with Windows 10 from Mint Live USB, the process is quite smooth and I have both OSs running fine with grub. I let Linux Mint installer auto-take 50 GB of Win 10 partition, it auto-install grub too, and I will select Linux Mint or Win 10 on Grub when the Ubook Pro startup.

I tried to install Linux Mint 19.3 using the installer both in regular mode and compatibility mode. I saw the mint logo on the screen, but then the UBook Pro just ends up shutting down on its own. Not sure what that’s happening but it’s really annoying. It seems local to just me, since you were able to install no problem. Any ideas on what I’m doing wrong?

1 Like

If you can load Linux Mint Live just fine, than there should be no problem install it to SSD, too.

I am amateur Linux user, however you could mimic what I did:

  1. Boot Linux Mint Live 19.3 Cinamon
  2. Choose install Linux Mint (connect to internet first)
  3. Choose the second option, install on the same Windows partition.
  4. Set about 50 GB free space as ext 4 for Linux Mint
  5. Auto-install on the next steps and reboot

Voila, you have dual boot both Win10 and Linux Mint :grinning:

I have the same problem as meee41.I even disabled secure boot, but system shutdowns during boot from any linux. Tried Ubuntu 19.10, Ubuntun18.04 lts,Mint 18.3, clonezilla, chromium os. My tablet is M3-8100Y.
@Meee41,Did you manage to install any linux ?
@ryukenshin , Did you change anything in the bios, and is your tablet with M3 or N4100 cpu?

I have not been able to successfully install any linux distro on my tablet. There appears to be an issue with some of the drivers that causes the distro installation gui to try to cycle through older drivers that may not be available until it times out and shuts off. This happens after you get to the grub or associated bootloader menu but before the gui finishes initializing. As the gui tries to get its ducks in a row (like in my case getting the wifi driver nailed down so that it can use wifi as part of the setup) it ends up hitting this failure and stopping the install. I only know this because Deepin throws those errors on the screen. Other distros I tried to install just shut the computer off.

I believe the only solution would be to manually initialize all of the drivers (if possible and compatible) through the terminal and proceed with the install as such. However, if the drivers don’t work with the install, there’s little hope they’ll work right with the full distro. Also, I’m not that adept to be able to try to manage that. I was hoping that someone on the forums had a solution but honestly i think this has to go to the engineering team. It’s very frustrating. I think we should all request the engineering team to at least post a video tutorial on how to get linux installed correctly specific to this tablet. I can just wipe the whole OS but the drivers will be a more specific problem…

I don’t believe that any engineers@chuwi can make instructions to fix the problems. I think the problem is the bios or the settings in the bios. The tablet is made from fairly standard components, which are used in many laptops that successfully run Linux.
I tried many different settings in the bios, but the result is always the same = I cannot boot any linux.
I guess that you also have a M3-8100Y system and @ryukenshin has N4100 system because he managed to install Mint 18.3.
Or I could be wrong, and that would mean that Chuwi has different components in different batches of the tablet.
My idea was to tripple boot Windows, Ubuntu with Andbox and ChromeOS.
I had the same setup on my old Dell 7140, and was pretty satisfied with it.
It’s a pity that Ubook PRO looked like the perfect system (hardware-wise) to replicate the previous setup I had. And now I have to go back to the old DELL.
On the indiegogo page, someone asked whether Ubook PRO supports linux, and the answer from Chuwi was: YES.

Yes I have the m3 version. I don’t know of anyone with the m3 that has successfully been able to do a dual boot. If anything, it seems that all of our installs fail for the same reason. I believe the tablet supports linux because the parts are pretty standard but I also believe there is some trick to it or something we’re missing. If you’re used to Chuwi products, you know the bios is as basic as possible. There just aren’t that many settings to tweak, and if the problem does lie with the bios, there’s no way to change a setting without a menu option.

Either way, the engineers at Chuwi clearly know the way it should be done, so I think they should show us the way. In a similar fashion, if drivers or the bios is the issue, only the engineering team would be able to deploy a fix for us anyway. I’m very frustrated at the fact that I cannot use the tablet or configure to my liking which ultimately is the reason to purchase any kind of technology.

Has anyone successfully been able to install linux on the m3-8100Y in a dual boot setup? I would appreciate you letting us know. Otherwise, we’ll have to report this as a product defect or something.

Really? Will you have to inform yourself the same if you can’t install Linux on an iPad or a Surface?

@manonegra222 Yes. If the company sold variants that came with linux preinstalled and also claim to support linux, absolutely. I’m not trying to be a butt about it, but it is a little bit of a let down. Also, if my intention were to dual boot then I wouldn’t buy something I know not to be compatible with that setup. For instance, I wouldn’t buy an android phone if I specifically wanted to use iMessage. However, if I bought something that claimed to support iMessage and the company even sells some phones with iMessage preinstalled, I think I would be allowed to be upset if I bought the item and then could not install iMessage. The situation is the exact same here. Considering PCs with nearly identical specs can support linux no problem and that Chuwi says these tablets support linux, is it not wrong to say that I’m at fault for being frustrated that the computer won’t support something it should support and is supposed to support?

In all honesty, I know the Chuwi team works very hard and buyers are quick to complain. I’ve bought several chuwi products and installed linux on every one I wanted to. I support this company and what they produce. I believe I’m allowed to voice concern over incompatibilities with installing linux that don’t exist on lesser quality devices on other brands. I wouldn’t be a good supporter if I didn’t call attention to this issue in the hopes they can come up for a remedy.

Finally, I’m not here to start an argument; I’m here asking for help. I appreciate your commentary chastising me for making fair (in my opinion) criticisms; however, I would also appreciate your input on the underlying issue. And if you don’t know how to fix it, maybe you know someone who can. Either way, I’d kindly ask that you focus on my questions more than just my criticisms as I stay a loyal supporter of this brand and this forum.

First of all, thank you for your response and allow me to apologize for whether my response has seemed sarcastic, it was not my intention.

It is very pleasant to receive reasoned comments and with legitimate requests although they are usually very scarce. In the forum, most of the comments are critical, due to problems encountered but in most cases they do not explain the reason why the problem was found and we have to act a little detective. No one acknowledges an error or improper action.

I am not knowledgeable about Linux systems, but it is true that Chuwi has commented that some of his devices were compatible.

I invite you to write to service@chuwi.com explaining your requests to try to get the installation you need.

Sincerely.

Enviado desde Correo para Windows 10

I apologize for being too quick to judge your response. I see you comment on many posts and you’re always respectful, polite, and accurate. I should not have assumed the worst.

In any event, I appreciate the email address you provided. I will reach out. Hopefully it’s a simple error on my part that can be easily explained for the benefit of the community.

As Always, Much Appreciated

@meee41
If you make any progress or get any info back from Chuwi, please keep this thread alive.
Meanwhile I tried to boot with 5.x kernel, and the problem was the same.
On the facebook group for supporters of Chuwi Ubook pro, a single post indicates the same Linux problem.
Also, it seems that the same problem never got resolved with the previous Ubook NON PRO.

I was never able to install Linux Mint 19 on the Ubook (NON PRO). So it
sits new, unused. Still would like to sell it if anyone is interested.
Thank you.

I reached out to support and they said that special software is needed to install Linux on the UBook Pro. When I asked if I could have access to that software to install Linux on my own, they told me that it is recommended that I stay with only Windows as it is stable and the engineers have not made any optimizations for Ubuntu/Linux in general. Looks like dual boot won’t work at all with these without them doing it for you, which it doesn’t seem like they want to do.

It seems like a GAME OVER for all of us that want/need linux on Ubook.
If the producer of the tablet states that LINUX is not directly supported and there’s previos experience with problems with linux:


We should forget about linux on Ubook.
I have only one problem with Chuwi:
They stated that Ubook PRO will work with Linux on Indiegogo, and they did not deliver.
Don’t get me wrong, Ubook PRO is amazing value for money if you are looking at Windows only tablet.
Most Surface products work with linux.
Even Microsoft’s Surface GO (same price range) works with Linux:

Fydeos - ChromeOS fork (linux kernel) works with many Microsoft Surface devices

Pity, could have been the perfect tablet (for me).

Well, I have no trouble install Linux on Ubook Pro N4100 version, I don’t know if there is anything changes in m3 version, however the most suspicious one is mainboard’s driver is not generic intel’s mainboard.

You could try to send diagnostic information to Linux’s user forum and hope that some experts could compile a compatible driver for Chuwi M3 mainboard :expressionless:

Are you able to choose a boot system without a keyboard in Grub? Can it be a combination of existing buttons?

I always have the type cover attached, however i think grub is setup to automatically boot to Linux without any keyboard input after 30 seconds.