Installation of Android on uBook pro n4100

So… I might have overdone it. Got last week my uBook pro n4100 and i fell in love with it… I ditched my Android tablet, I’m selling it and i bought another uBook pro n4100 to install Android on it.

That’s the plan anyway… Thing is I’m not finding anything about running Android on it either in this forum or outside. My main concern is drivers… Does Android have the drivers for this tablet, specially for the screen? Has anyone here tried to install Android on it?.

To clarify, i use Android pretty much only for reading, because certain apps that i use work only in Android. I tried running BlueStacks on the tablet and install them apps there (that’s what I’m doing now) but having two OS running at the same time with this cpu… Is rather laggy. It works for reading, but sometimes even changing the page can be rather frustrating, so i would love to have one of them with only Android installed in it, or even dual boot.

Also, to clarify even more why i need two of them… One is for outside work, which means i cant have any suspicious or compromising material in it, because i work as a civil servant for the city hall… And the other is just for personal use.

I did run Cloudready Chrome OS from a flash drive on the Ubook Pro. Most of the drivers appeared to be there. I did have an issue that sometimes the touch screen would not work.

Which version of Android did you run? I saw there is even Android 10 for pc? Maybe de newer the better? I mean, newer version may had the correct touchscreen drivers?

Edit: wait nvm I’m an airhead, i read it again lol…chrome os is based on linux or Android?

Chrome OS is from Google and is supposed to be able to run some Android apps. But I didn’t test that part. I was just checking to see if Chrome OS would actually run. It is fairly easy to put Chrome OS on a flash drive and run from it.

I managed to run Android 9 over an usb 3.0 drive, and it works fairly great except for the touchscreen. Wifi, Bluetooth, orientation sensor, works. I yet have to install it and see if it reads the ssd too and maybe installed it will install drivers for the touchscreen too.

Yeah, I had the same issue with Chrome OS. At least that is consistent. For Android, you might have to search for Nanjing/Goodix Touch Drivers.

1 Like

Thanks for the names, I’mma look around. For now i somehow fucked up the boot messing with Android and had to install Windows 10. Tried all ways of repairing the boot and there was no way it would boot to windows again. I installed windows 10 and partitioned the drive and made a multi boot with windows 10 and Android 9. Both are working but both are missing some drivers lol. Android is missing the touchscreen drivers and windows is missing 5 HID drivers.

Today the second unit arrived. I want to do a disk image before doing anything to it and save it for the other, and maybe upload it and link it somewhere in the forum. Though, I’m having issues with the tablet not running legacy bootable drives… Wondering if the tablet is only UEFI boot capable, and has no support for legacy boot

i now have a multiboot with a clean windows 10 install and a fresh android 9 rc2, each in its own partition,

i fixed all the missing drivers on windows, but i can´t find anything related with this touchscreen for linux/android.

android 9 rc2 was launched a few days ago, so i had hopes it would have the drivers for the touchscreen, but nope.
i even tried Bliss OS, and still got the same problem…

it’s such a shame, because android on this device runs really smooth.

any news?

I know this is old but Bliss OS 11.10 works and has Google Play Store installed and working. Also Android X86 9.0 is stable and the touchscreen and everything works. You can install either on a USB thumb drive and try it out before installing to hard drive. For anyone interested in dual boot android and windows.

i tried bothe bliss os and android 9,0rc1 and rc2 and none has drivers for the touchscreen

Wait, bliss os does recognize the touchscreen but only if when you turn it on, you have the keyboard connected and select (old modprobe mode). After you get to the Android desktop you can take off the keyboard and it will work properly except the orientation sensor, but you can fix that with an app to switch manually the orientation

that’s correct regarding the orientation. My Ubook is the same. I just use an app from the Play Store to set the tablet to landscape since I use my Ubook mostly with the keyboard. The one thing I haven’t been able to resolve is that most games from the Play Store force close. You can install them but they won’t open. That’s kind of the only problem I have with Bliss or Android X86.

Hey guys…

I’ve just received my Ubook (not pro) and came here to see if is there any viable google system (android os ChromeOS) to the tablet. Did you guys find out a solution to missing drivers? What is the best operational system option?

Bliss OS 11.10 in old modprobe mode. Run it from a pen or install it on the ssd. To have the touchscreen work you need to turn it on with the keyboard on until you go to the Android desktop. The orientation sensor wont work and you need to download an app for switching the orientation of the screen. Also sometimes the wifi will stop working as soon as you turn it on. What i do is turn it off as soon as it starts and the after all loads i turn it on again. Also, most of this was already posted and you only had to read it…

Bliss OS 12 хорошо работает.

So… guys. I think I have another problem here. I managed to try Android X86, and it worked almost fine. But, i was unable to try other OS cause I allways get stucked on usb boot. Bliss, Cloudready, Fydeos… every one of them starts the usb boot but it doesn’t finish loading.It stucks on brand logo e never goes on. Am I doing something wrong. DO I have to change something on Bios?

Hello guys!
I have just bought this tablet laptot and I want to have both systems Win10 and Android.
I have tried to run Bliss 12.5 in live mode but I cant
Any other distros or ideas to have dual boot in this tablet?
Any step by step tips should be grateful.

Hi friend, I am new. You tried to install 12.5? All works fine in dual boot? Thx

No I didnt try First I try to boot in live mode but it stuck loading for that i didnt go on!

I put it at 11.6. But it does not differ in installation. I am happy with the installation of the official release (first) of Bliss OS 12. I checked all its functions. Turning the screen doesn’t exactly work, but I don’t need to. The main thing for me is that it supports sound, Wi-Fi, Bluetooth, external media. I’m happy with. Now I deleted it by accident, I tried to update to the Yantra version. It didn’t load because the loader didn’t work. I will experiment further. Try the lighter version of Prime OS. There is an installer right from Windows, safe.