Chuwi Aerobook keeps switch off as if power button is stuck

Backed the Aerobook on indiegogo but few days back it doesn’t want to boot. It is acting as if the power button is stuck or something. Found a way on youtube by holding the “~” tilde key and was able to boot into Windows and backup my data. However once I release the ~ key, windows will initiate shutdown and it will switch off like how it would react when one press and holds the power button and cuts the power.

When powering on without holding the ~ key, it will show boot screen for a few second and switch off again. Anyone encounter this issue? How do I get it fixed in Singapore?

Please contact aftersale@chuwi.com

I am also encountering the same problem. I have to hold down the “Windows logo” button to switch on the AeroBook.

Once I release the button, the AeroBook switch-off again.

Can Chuwi assist with this problem?

-Wakdidin-

Same here and no response. No way to get info on bios for aerobook.Please post bad reviews on Trustpilot, maybe that wakes them up.

Understand that there is no one working in Chuwi since January 20, first for the Chinese New Year celebrations and then for the problems caused by the coronavirus, which has delayed the return to work to February 11

Sorry for the late reply, as you know, China is fighting the epidemic.I just got back to work today.You can describe your problem to service@chuwi.com.Please understand that the reply may be later than usual during the special period.

1 Like

I have the same problem today

i managed to get them to send me a “new” keyboard after 2 months. The keyboard arrived, with missing keycap and the cable pin has got some black patches. Tried to swap keyboard, doesn’t work…

service@chuwi.com never did reply my multiple emails. The keyboard was sent by their indiegogo rep, which i backed the laptop from. They wanted me to send the laptop but local postal just won’t take it due to li-on battery inside (dangerous goods). To send by Fedex or DHL would have cost another hundred.

US$400 down the drain, no support whatsoever. will NEVER EVER touch a CHUWI product again…

Help i am also encountering an error today

I just registered here today to report the same exact issue as markietan

Please tell me your email address.

lawrenceboadilla@gmail.com is my email. Really need my aerobook for work.

Not my first time having issues with my Aerobook. I already bought and replaced a dead battery. I thought that’s the last time I would open my laptop, but no it wasn’t.

My keyboard also had the same issue after trying to update Windows.

I confirmed the keyboard is not working properly when I tried disconnecting the ribbon after booting up. The laptop stayed on the whole time.

I’m looking for replacement keyboards online but could only find non-english, non-backlit ones.

Please help. My work is already affected because of this.

Hello, for accessories,parts, please contact aftersale@chuwi.com, our service department will help you out. If you don’t get a proper reply in 24hrs, please tag me again, I will follow up on it. Have a good day!

I’m also facing the same problem with my Aerobook. Anyone got their issue fixed?

I still haven’t received my replacement keyboard. What’s going on?

Can you help me track my order LP352508091SG

I need to use it for work.

Thanks

I also have the same problem. Please tell me how I can fix it.

I have the same problem. What is up with that tilde key “~”. Its the only one working. Thanks to the guy who mentioned that by the way.

I have sent an email to both sales@chuwi.com and aftersale@chuwi.com. Hopefully I get a reply soon. It would be nice if there is a solution that won’t require me to send my laptop back to china.