Chuwi forcing GPT on MBR partitions

I managed to install Windows 10 (both the original iso from microsoft and LTSC).
But there’s a problem, the partition comes by default on GPT, I convert it to MBR on the windows installer using FN + SHIFT + F10 to launch the command prompt, and use diskpart to select disk-clean-convert to MBR.

Everything seems fine but once the installation starts, it converts itself into GPT again. What could be forcing my installation to use GPT instead of MBR?

I used rufus to create both bootable USBs and and made sure to choose MBR, so I assume there’s something on the laptop forcing GPT. I disabled secure boot and CSM is enabled, I have both UEFI and Legacy enabled, every entry says UEFI (storage, web, etc). If the installer is created as MBR, and the disk appears to be converted to MBR with only allocated space showing, why is it going back to GPT?

I’m not sure what else to do and I’m getting desperated, I bought the laptop for some specific apps and they all show greyed out options I need because of GPT, I can’t even do a full disk encryption because the option is greyed out.

Any idea on what to do? I feel like the laptop is limited on the BIOS for some reason. Is there an email to contact tech support directly?