Windows 10 rescue

Hello everybody,
I had installed Windows 10 and Linux Mint on my Hi10 air.
Now I want to make a test and deleted the Linux Mint partition! This was not a really good idea, because now the GRUB bootloader do not work anymore!

GNU GRUB version 2.02
Minimal bash-like line editing is supported. …

Is there any chance to repair the MBR, so that windows 10 will boot?
I don’t like to flash completely because of the settings I have in win10 and data…
I can boot any system form USB, no problem…

Thanks and best regards

You need to fix mbr : bootrec /fixmbr
If that doesn’t help - fix boot : bootrec /fixboot

Also if you can run windows setup you can enter in troubleshoot and try to fix boot with inbuilt firmware from microsoft.

Thanks for your quick reply.

It doesn’t work with the bootrec commands! I don’t understand why, but tried a several times.
Also the windows setup booted from USB cannot help.

Now I found out if I set the boot in bios for the windows partition, windows boots well.
So it seems I must change UEFI boot, but this is not possible in bios. So I must try to fix in Windows.

Maybe install new bios uefi could be a solution.


you can try this command from windows usb boot:
bootsect /nt60 c: /mbr
it will build MBR.
worked for me on my Ubook Pro

Good morning,
thanks for the idea, but it doesn’t work.
If I select in bios “boot override” the “Windows Boot Manager” my windows starts one time.
But after reboot still the same problem.

I think its the uefi hard disk drive bbs priorities, but I cannot change.

Can I reset bios?

Thanks Markus

What about copy windows partition, then delete all partitions and launch windows installation to make clear boot partition?

But if I make new windows installation, it will not change the bios boot setting!

There is no linux partition, but still in bios!

Can I load any factory setting or installation?

You can just reset it from bios in save&exit tab. I don’t think this is bios firmware problem.

Ok, so only way is install windows.

The crazy thing is that windows works fine when I boot directly in bios, I only cannot fix the boot manager, haha.

So I can do installation also in windows directly and try,all settings I made for touchpad and pen will be lost.

You can make full copy of windows partition and try to replace new windows with your copy.

This 3 programs are very good in partition copy and recovery.

OMG, I just made new windows installation, but still the same problem.

Can I flash my chuwi completely new with the keyboard usb?

Yes. Have you deleted all partitions or just started automatic install?

yes, but in bios still the boot option priorities are

dont understand what I have done with my Air…

Think now I also can try to get another linux running, because now nothing is running, haha

Try to delete ubuntu from efi shell. In tab save&exit choose launch efi shell. Write “bcfg boot dump -v” , you must see ubuntu boot, then write “bcfg boot rm X” X- number of ubuntu boot.
I’m out of ideas :sweat:

Hey, thanks for all the ideas, I started already to flash my air new.
Normally then it should work…hio I only must find the right settings for my pen and fix the touch pad problem.
But everything should be fine, haha…

@all: I fixed the problem with a factory reset by flashing a new windows system.
Now everything is ok with the boot options.