Hi 10 Air Bios reset?

Hello people,

Is there any official bios reset procedure for hi10 air? I purchased an hi10 air, and the windows came asking for repair. None of repair options were working, so i went to reinstall from chuwi officla tutorial. Then, the flash drive was not recognized at boot menu(boot menu shows only “windows boot manager” and “enter setup”), but it was recognized in the setup. So i though that may be a usb configuration, then i disabled xhci on setup. Now the tablet is not recognizing the keyboard, and i need to reset the bios to get usb devices working again to try to reinstall windows. Please help!

First option:

  1. turn on - the LED starts flashing
  2. hold the power button until it goes off
  3. release and immediately press the power button back
  4. wait 20 seconds and release
  5. turn on

Second option:

  1. Press the power button for 30 seconds.
  2. Press the power button 3 times for half a second
  3. Put the charger and try to turn on.

Also make sure there are no hidden partitions on your usb drive or you can try to use another usb that has never been used for any kind of system \ live image.

Hello, already tried both ways. None of them worked :frowning:

But usb drives are not recognized, because i disabled xhci on setup. Now I can’t even enter setup because the keyboard is not being recognized :frowning:
I just need to reset bios, but the two ways that user biosham shows are not working.

This is strange. Try discharging the tablet completely and leave it discharged for a few hours, maybe the bios will reset.
You can also disconnect the battery for a few minutes.

If this does not help, most likely the only way will be to flash the bios via SPI programmer.

I contacted chuwi support (aftersale-service@chuwi.com). They asked me for pictures, I sent them. I told about the bios config I changed, told them that I need to reset the bios, and they replied me:
“Hello, I suggest you send it to a professional for installation”

What is that? There is no way to reset the bios without opening and reflash? Very disappointed with chuwi brand…

Chuwi tablets and laptops use nvram instead of cmos, which is more stable but have some cons (you can’t reset absolutely all setting by leaving motherboard without a power).
But in any case, these combination MUST work even if your tablet not turning on.

After a correct flash of the bios that ended well with a green screen.
I tried the 2 methods that always lead me to the Chuwi logo.
I also unplugged the battery and plugged it back in before trying both methods again.
Again, this leads me to the Chuwi logo which remains indefinitely.
How can I find Windows or its installation procedure because my Chuwi is unusable, it’s very frustrating?

20210308_085909

Windows
[Hi10 Air] [Tutorial] How to reinstall Windows 10 for Chuwi Hi10 Air

I have the same problem, but i have chuwi hi10 x.
I also send them pictures and video what is happening.
I didn’t find any solution yet.
They did send me bios but i can not flash it only if i buy all equipment and take tablet apart.
PLEAS let me know if you figure it out somehow.
Tnx.
Aleksander

If the bios does not reset after disconnecting the battery, you will have to flash the bios with a programmer.
Take the tablet to any service, they will flash it in an hour or two.

Yes but i live in Slovenia, we dont have service here, and sending it to chuwi will be expensive.
Do you maybe know the cost for reprograming ?

In my country (russia) it will cost 13,43$.

Oh that is not that expensive, but probably shipping will be arround 50€.
I found how to reset the bios on nvram on datasheet i tried to ground the 2 pin witch should be for hold/reset, but it’s not working tablet still boots directly to bios and i don’t have keyboard.
I thnik this kind of setting should be disabled (to change) in bios.
I probably disabled usb xhci by mistake so now my usb does not work and i dont have OS on tablet so… Big problems :slight_smile:

I have of course done this successfully, it has even been done several times. I did get the green screen at the end.
The problem is that then there is neither Windows nor its installer, just the Chuwi logo.
Even if I choose the appropriate bootable media with the F7 key, for example a bootable USB key (Windows or Acronis rescue boot, GPARTED, etc…), this system doesn’t boot, while all of them boot perfectly with any other PC or tablet designed for Windows. This is very frustrating.

Probably you have dead eMMC.

There is new information. The TPM may be causing a boot problem, try disabling it.
Advanced-> Platform Trust Technology-> fTPM