Chuwi Hi10 Air won't boot to any bootable OS

Good Day Everyone,

I am having an issue with my Hi10 Air. I have been dual booting other OSes just to test its capability and compatibility to other OSes. I tried the Android x86 and other Linux distros. It works a couple of times then I installed back the original version of windows 10 that I downloaded from this forum, then after a forced windows 10 update it suddenly stops booting. I have tried booting a windows 10 image from microsoft and other OSes that have worked before and it doesn’t boot them anymore. I can still access the BIOS, and tried resetting to factory defaults and still doesn’t boot. It only goes black when I select a bootable device, or when I just leave it to boot, it will just show the chuwi logo forever.

I was wondering what went wrong in the process as I have not encountered this from any of my experience. I understand that the Hi10 Air is not a typical laptop, as it is an ARM base device. If anyone of you have the solutions or also have encountered this problem, please let me know.

Note: I also tried contacting the Chuwi support, but sending my device would be costly for me as my country charges a large amount when sending a parcel abroad.

Thanks and hoping to solve this problem.

Probably you have bad EMMC, check what is displayed in the bios - chipset->south bridge->lpss&scc configuration. At the top you must see name of internal memory.

1 Like

Thank you so much for the reply. I have checked what you said… here is a screenshot

It seems it says unknown. However it can identify a model number or something followed by the size.

Is that a bad emmc?

You have Micron memory installed, it is never detected correctly, so it’s hard to say 100% that the problem is in memory. If there is a color mark on the memory chip, then most likely your motherboard has already been repaired earlier and the problem was with EMMC.
Try to run RAM test.

1 Like

Edit: No luck with the mem test. It won’t even boot the mem test that i created from my flash drive. It’s stuck in a blank screen when selected.

Can’t say for sure about the device being repaired before. I just bought it brand new from our country’s online store. But I’ll try the mem test if it can boot it. Thank you so much. I’ll get back to you for results.

Any updates for this?