Chuwi h10 air factory reset

How reset the h10 air to clean factory state. It seems there is a recover partition on the drive. How can i use that partition for reset.

This partition made by windows. To reset windows select start->settings->update&security->recovery->reset this pc. Or you can reinstall original windows with usb drive using this files

Do we want RS6 or RS4? RS4 appears to be standard WIndows 10 x64, but RS6 appears to be an insider preview. I got the tablet secondhand and it had Ubuntu linux on it and while it works, the touchscreen does not and bluetooth does not.

You can install any of these builds.
For fixing touchscreen and BT try this:

The Hi10 Airs Silead touchscreen requires drivers that are not bundled with a Linux install. You can download them here: https://github.com/oni…/master/firmware/linux
See the Readme on how to install them.
These drivers get loaded by the Linux kernel. I submitted a commit to add support for the Hi10 Air to the Linux Kernel and it has been approved. The commit is merged in the 5.1 (and newer) Kernel. That means you need to update your kernel for a proper touch support.
Bluetooth
Install blueman and follow the firmware instructions mentioned here:
https://github.com/lwf…issuecomment-432806835
Which means you need to clone https://github.com/lwfinger/rtl8723bs_bt
and run
sudo cp rtlbt_fw /usr/lib/firmware/rtl_bt/rtl8723bs_fw.bin
sudo cp rtlbt_config /usr/lib/firmware/rtl_bt/rtl8723bs_config.bin
cd /usr/lib/firmware/rtl_bt
sudo ln -s rtl8723bs_config.bin rtl8723bs_config-OBDA8723.bin

Thanks, but no. I’ll stick with WIndows.

Edit:
RS4 installed perfectly. The instructions say that the device will automatically shut down but in my case this did not happen. Manual shutdown worked. Windows 10 is installed and activated.

Hi, which Ubuntu Version was installed on you Chuwi Air?
I tried Mint Linux and it was very fast compared to Windows, but was not able to get Sound and other things running.
Now I fight to get Windows back, but to be honest would be nice to get also linux running.

Thanks
Markus

It was 19.04. It worked great, other than as a “tablet” because the gyroscope and touchscreen weren’t functional. Everything else worked.

I needed a Windows tablet more than I needed a Linux laptop, so Windows won.