Chuwi Minibook does not start with SSD

Recently, I bought a Minibook model m3-8100y with 8 gb RAM and no SSD. As per the page and specs, it states that it supports SSD M.2 NVMe.Unfortunately, when I tried to put the SSD, the Minibook won`t even boot, but when I retire it, it functions normally.

The SSD that I am trying to put is the following: Sabrent Rocket 500GB M.2 NVMe which fits properly, but I had that issue. Could you kindly let me know what to do in this case? By the specs, it should be compatible with the system. If not, which one do you recommend?

Clarifying: I cannot even get to BIOS. The Minibook does not start when the SSD is plugged in and without power supply, with the power supply the keyboard is lit but the screen does not show anything.

When there is no SSD, it works properly without issues.

Another thing that I have is that I cannot connect the Minibook with a TV via HDMI from the USB-C port on the minibook. Is the Minibook DP alt compatible?

Your SSD is probably defective.
Try it on another machine to see if the problem persists

Hi,

Tried on another machine as suggested. There was no problem, the other machine started and booted normally. The SSD was recognized under the Device Manager. So the problem probably lies within the configuration of the Minibook.

It’s strange your problem.
Go take a look in the bios to try to make it detect itself
For my SSD transcends, I did not need to do anything for the MiniBook to detect it correctly