Chuwi Surbook no sound after fresh windows 10 install

Hello,

I installed a fresh windows 10 image from the Microsoft website, the latest version.

Then I downloaded the drivers set , shift restart , 7 ,
and i installed all missing drivers.

All is working except the sound!

It does nog recognise the drivers!

How can I fix this? Where can I download good drivers for the sound?

This is the only thing in the device manager that shows a non working yellow triangle.

Thanks for your help!

Hello, please contact aftersale@chuwi.com, our service department will help you out with this issue.

They send me the link. I downloaded the drivers. When I try to install the driver I get the following error

WINDOWS WAS UNABLE TO INSTALL YOUR MULTIMEDIA AUDIO CONTROLLER.

WINDOWS COULD NOT FIND DRIVERS FOR YOUR DEVICE.

what now?

It is a purely Windows issue and its protections for the installation of digitally signed drivers. In addition, you must also perform the correct driver installation procedure, using the specific path to install drivers from a specific location.
I will try to transfer all the steps to solve your problem from a thread in this forum that gave instructions for installing the drivers to another user:

“It is logical that, after a clean installation of Windows, the system does not recognize the drivers of non-Intel devices. This happens on any device of any brand.We must then install the drivers that Windows has not been able to install.To do this, after downloading the drivers of our tablet or laptop model and unzipping them into a device storage folder, disable Windows protection for the installation of unsigned drivers.To deactivate this protection, press start, restart with the shitf key pressed, and restart now. When you restart, an advanced reset screen will open in which you must press 7 or F7 to deactivate the protection and it will restart normally.
It is time to go to the device manager, by clicking on the start button with the right mouse button and in the menu choose device manager, and see in the device tree the drivers that are not correctly installed. (they have a yellow triangle).You have to click on each of them with the right button, driver properties, update driver. On the next screen, choose the option below “search for driver software on the computer”. On the next screen “choose from a list of available drivers on the computer” and on the next one you must click on the use disk button; The browser will open and select the folder where you have unzipped the downloaded drivers, checking the option to search in subfolders.The system will install the device driver. You have to repeat this process with each of the devices with a yellow triangle. Keep in mind that if you restart, the protection will be activated again, so you must activate it again when you have to install a driver.”

I hope it helps, if not, let me know

I have a lot of experience with installing windows. Ms dos, windows 98, windows xp , windows 7 , windows 8, windows 10.

What I have done is, I have installed the official windows 10 iso from the microsoft website.

Then , restart with shift , 7, etc.

There are 5 or 6 items in the device manager that have this yellow triangle. I can install drivers for all of them!

EXCEPT THE AUDIO! It won’t install the audio driver, because it can’t find it, even though there are drivers in the audio directory from the drivers set.

So now I read somewhere that one must first install basic intel audio drivers and then the drivers from the manufacturer.

But all I want is correct drivers for the audio from the manufacturer. Which brand is the audio hardware, intel?

Here are the drivers for my SurBook. You can install them manually or with the doubledriver app. Everything works on my tablet.

https://1drv.ms/u/s!AqpKvT8-VB_8zwXyT_s0I4q17gO3?e=MtWo45

Thanks for the upload! I downloaded the media map, unzipped it and restarted my pc (shift start) , etc. , press 7 (no signed drivers etc) and then device manager, update drivers, search manually on my pc, go to the media map (incl. subfolders).

(The audio device appears in the “other devices” on the device manager. There were 5 devices there, all “unknown” devices. 4 of them installed perfectly earlier this week and then disappeared from the “other devices” but this “MULTIMEDIA AUDIO CONTROLLER” is the last one to remain without a driver)

So I try to install the driver…

And then…l got the same message!

Hahaha, this thing is killing me.

So this is the problem I think.

There is some basic driver in the windows 10 iso that I can download from chuwi itself.
I did not install this windows 10 version, I installed the latest september 2019 version from the MS website.

So what i also tried to do is reinstall the official chuwi old 2017 windows. But when I do that it does not install windows. At startup it does something , then leaves me hanging in a dos window in the system32 directory.

It does not go through with its installation.
I try to figure out why (it is not an .iso but a map with the installation maps and bootfiles) but I can’t fugure it out why.

And believe me, I have installed more than 20 pcs so I know a bit how to to that.

UPDATE!

I downloaded now ALL the 900 MB drivers from you and then just let it search for any driver.
It found some realtek driver and then still no sound.
But then two new devices with yellow triangle appeared in the device manager.
Again, let it search in your 900 MB driver map and then…

IT FOUND THEM AND ALL IS WORKING FINE!!!

THANKS DUDE!!!

1 Like

I’m glad that everything is working again. There is no better reward for everything to work after the great work you have done.Keep the drivers in a safe place, although my constitude is to extract them from the newly received devices and save them for cases like these.

Thanks again, the thing is, I want to sell it, that’s why I deleted all the files with an official windows restore.
Which fucked up my system, I could not log in anymore!
You get “another user” screen which is not fixable.
Microsoft knows this but they are quiet about it, so they “advice” to do a clean install.

It took me one month to come this far where I am hahaha.

Thanks and be careful when you want to “clean” your system!

I will never have that problem since, in addition to extracting the drivers of the new device when I receive it, I also make an image of the disk before connecting the computer to the internet, so, if I sold it, I just have to restore that image and everything It will remain as newly received. The program I use for this is Macrium Reflect, which has a free version.

I have similar problem and still not find any solution for this problem. How did you clean install windows on your Surbook after reset it?

Hi Jokosusen, welcome to the official Chuwi forum.
If you explain your problem we will try to help you.

Hello Jokussen, i just downloaded windows from the microsoft website, they have an installer for you

https://www.microsoft.com/nl-nl/software-download/windows10ISO

This is the dutch website but just google “ windows 10 clean install” and you will find the us version.

After the install i downloaded the drivers ( not the ones from chuwi, they are not good. Can’t believe it myself, but chuwi is not capable to put the good sound drivers online ! )

You must download these drivers. They do work!

https://onedrive.live.com/?authkey=!APJP-zQjirXuA7c&id=FC1F543E3FBD4AAA!10117&cid=FC1F543E3FBD4AAA

I want to give my Surbook to my cousin, so I reset the device with fully clear the personal data etc, I’m using reset tools provided by windows. After resetting finished, then I caught up with other user login, with some tips from Youtube, I can finally create administrator user and password, but after log in, the desktop is blank with notification that desktop profile is missing. only windows logo and recycle bin icon appears there. I can do nothing then. I tried to install it again from USB but it can’t access the USB (device is not ready). Can you give some suggestion?

I have been trying ONE MONTH (!) to do exactly the same as you, so I am the NUMBER ONE expert in the world when it comes to this problem!

So the first thing that you should NOT do is “restore” your windows tablet.

In one of the recent updates Microsoft accidentally made a mistake that fucks up your system when you restore it! They are quiet about it, but we should sue them for it! They owe me at least $5,000 for the trouble they gave me.

Because when you do this, you are getting a “ANOTHER USER” login screen. And you can’t get in !

So what should you do?

  1. Get a clean 16 gb usb stick
  2. Download a clean windows 10 image ( with installer ) from microsoft.com
  3. Make a bootable image on usb
  4. Put usb stick in surbook
  5. Start surbook, press escape
  6. In bios change startup sequence, select usb
  7. Install windows
  8. Download the good drivers
  9. Restart Surbook (with SHIFT) and go (with 7) into special non signed driver mode.
  10. Install the drivers!

Thanks for the advice, I will try it

1 Like