Chuwi ubook pro not charging

How to resolve Chuwi ubook pro not charging with original charger used?

Chuwi UBook Pro is not yet for sale, how is it possible that it already has it?

So, are you a professional black fan? So interesting.

I am not. I am a frustrated buyer who supported the kickstarter and I received an Ubook that does not charge!
Can you solve my problem before accusing me a black fan!

Our Ubook pro hasn’t been produced yet, even on a prototype.How can you receive it?

I meant the Ubook 2-1.

You need my product ID to proof?

That is more reasonable.
First we have to find out if the problem can be with the tablet or the charger.
If it is from the charger, it can be from the charging module or the connector.
If you have means, such as a polymeter, try measuring the charger voltage.
If you have a type C charger (with Power Delivery) can you try to charge the battery with that charger?

I hv tried your suggestions. There is no light at all (blue charging light). I hv also used USB C. Still no blue light.

Write todo