UBook Pro dead after charging with USB - C

After trying to charge my UBook throughout the port USB-C, having +/- 50% of battery, I’ve found the tablet dead. No possible to switch on in any way.
I passed to charge it using the provided charger, for a full day with no result, no possible to switch on.

I’ve readed in this chat that a powerfull PD charger must be used. I did not used that kind of charger.
Is this a possible reason for the battery to be damaged ?
Any option?’

Can you put a picture of the used charger? if you have used a charger with more 12V voltage, the charging module may have burned

I will do, but I’ve used the official one, supplied by Chuwi.

Regarding the USB-c adapter is a normal one that I used for recharging mobile phones and other Android tablets, surely less than 12V.

El El vie, 7 feb 2020 a las 12:23, manonegra222 via CHUWI | Official Forum chuwi@discoursemail.com escribió:

The USB adapter causing the no reaction of the tablet connected to the USB-C port, is attached. A normal usb adapter from Google

It is a conventional mobile charger, only providing 5 volts and 1 Ampere. It is impossible to charge a laptop that needs 12 Volts 2 Amps with that charger.

Enviado desde Correo para Windows 10

You might want to try using a 45W PD 2.0 USB-C charger and see if that works.

I personally use a ZMI (Xiaomi) HA832 PD USB-C charger and it works just fine. It also has two additional USB-A charging ports (QC3.0) which is nice to have. It is not that expensive and I believe they have optional plug types (but maybe a different model number).

Also, if you use a PD USB-C charger, make sure you use a cable that is rated for use with PD charging.

1 Like

Yes, it is. Now I know that. So, no reason to have the tablet dead.
After that I’m trying to charge it with the charger provided by Chuwi, but no reaction. I don’t undersand.

Thank you for your comments.

Hi Silurian,
As commented below answering to the colleague manonegra222, this use of the wrong charger should not to be a sensible reason.
I understand the power loss but I don’t the no reaction with the regular charger.

Do you think a PD USB-C charger would work?

I think it might be worth a try. Otherwise, you can try contacting Chuwi support at aftersale-service@chuwi.com and see what they say.

It may be that you burnt out the charging circuit somehow using the incorrect charger and have to send it back for repair. I am not sure if it will be covered by warranty.

The use of a lower voltage charger should not cause any damage to the charging module. It is not understandable that the official charger does not work unless it is damaged (the charger)

Gracias manonegra222, this is exactly what I think.

In fact, I think the problem is not related to the charger but to the keyboard which is on once you try to charge whatever system you use, although the tablet is switched off, the keyboard light is on.

i’m afraid this is related to the loss of energy.
Nevertheless, this is just an opinion, no proved.

Have you tried to charge the tablet with the keyboard removed?

Yes, I tried. I’m afraid some circuit was damaged.
No option but contac the aftersale-service.

There is a solution for that. There is a thread in which the process is detailed

You may try to forced power off by long press of power button. My surbook mini was like that in the past and I pressed the button as long as until surbook powers on.

1 Like

Совершенно верно. Сначала попробуйте полностью зарядить его штатным зарядным устройством. Потом длительное нажатие на кнопку включения (почти целую минуту), потом, если не включится, отпустить и снова нажать для включения. Потом напишите результат. Ок?

Ok, thank you. If does not work I will give it back to Amazon. I have time to do it. It’s sad because the tablet is really nice.