Fix blurry issue on Chuwi Hipad Pro

Fix blurry issue on Chuwi Hipad Pro by setting up resolution and dpi. There is no risk in doing this. Feel free to try this yourself.

  1. Open Settings > About phone
  2. Tap on Build number several times until Developer mode activated.
  3. Activate USB debugging
  4. Connect to PC
  5. Enter adb devices via adb fastboot platform tool and allow USB debugging
  6. Enter adb shell wm size 1600x2560 to set resolution
  7. Enter adb shell wm density 480 to set pixel density

There is no need to reboot system to take effect. And the effect will stay even if rebooting Hipad Pro. If this is not crisp enough, you can try the following command lines
adb shell wm size 2424x3880
adb shell wm density 640

Please note that battery will drain quicker with higher resolution. Right now my Hipad Pro is set to 2560 x 1600 pixels.

For fixing reddish issue, try using apps that can change or calibrate color profiles. Type icc color profile in Play Store.

1 Like

Hi super :)!

Thank you so much for keeping helping us with this topic.

I will try it as soon as possible :wink:

Hello super,

Thank you for your information.
I immediately tried the original resolution of 1600x2560.
It seems a little better.
But I need a little more tuning.

Seems that changing the resolution does not depend on the SoC specifications.

By the way, Do you have any idea that why CHUWI change from the original resolution to the current resolution of 1940x1212?

Hello Tanzawa,

idk why Chuwi change the resolution to 1940x1212. Its Logo is also in this resolution when booting. When I set resolution to 2560x1600 everything is crisp. The contour of curvy shapes used to be jagged on my display. Now everything is crisp. The drawback of this higher resolution is quicker battery drainage.

Have you updated your Hipad Pro system via OTA update? If not, can you check your bootloader whether or not it’s unlocked?

Hello super,

I couldn’t check the status of bootloader or Lock.
Something seems to be missing, but I haven’t investigated it.

fastboot oem device-inf

----waiting something forever----

My HiPad pro did not need OTA, its already updated.

Hello Tanzawa,

No, please don’t update firmeware via OTA update, at least for now. Most users got locked devices after doing that.

Enter this fastboot command in fastboot mode:
fastboot oem device-info
You missed “o” in “info”

The easiest to check your bootloader is to enter bootloader mode. You can do this by 2 methods:

  1. In system, Enter adb command line:
    adb reboot bootloader
  2. When your Hipad Pro turned off, holding power + volume down. Until you see Chuwi logo boot up, release power. You will enter bootloader mode. You can see DEVICE STATE - unlocked or locked. Mine is unlocked. Hope yours also.

Hello super,

I get DEVICE STATE. it was locked.
I did not OTA update, and my HiPad Pro was WideVine L1 already.

Locked

Hello Tanzawa,
I see. Right now there is no official unlock tool for Hipad Pro released by Chuwi yet. I have no idea when this will be released. Or never.
You can try using fastboot command lines to unlock bootloader
fastboot flashing unlock
See more details here. Some users tried to unlock bootloader using fastboot command line(s) but still cannot do it yet. Maybe you can.

Hello super,

I tried fastboot flashing unlock from command line. but I can not unlock it.
No response to fastboot command from HiPad Pro.
Here are the steps for the command I tried.

C:>adb reboot bootloader
C:>fastboot devices
… nothing is appear
C:>fastboot flashing unlock
< waiting for any device >
…no response from hipad pro

Hello Tanzawa,

You need to do these before using fastboot to unlock bootloader.

  1. install adb driver
  2. go to Settings > System > Developer options > OEM unlocking

You can read the thread that I post here.

There are a number of Hipad Pro users tried to unlock bootloader via fastboot command lines but cannot do it yet. Seem like their devices need official unlock tool. Not sure if this would happen to your device.

Hi super,
Thank you for your advice.
I tried to your CMD line. But, the situation was not changed.
I can not unlocked my tablet.

So, I am going to waiting CHUWI’s formal update

Thank you for your sincere support !