Flashed GSI ROM on HiPad Pro and fixed reddish and blurry effects

Flashed GSI ROM on HiPad Pro and fixed reddish and blurry effects. Please see the attached image.
If anyone’s interested in doing this please leave a message. But be warned that you may void your warrantee by doing this.



4 Likes

Hello,

Can you provide a tutorial?

Thanks

The reddish issue is caused from color profile which is probably vivid or saturated.
And the blurry issue is caused by the blur function which may be new in Android 11 and the developer team did not create an option to turn on/off this function. So this blurry effect is activated by default.

I took risk to flash GSI ROM without waiting for the official stock firmware because I noticed that the reddish and blurry effects show up in many apps that apply the system settings rather than using their own settings. Most Google apps do this. I watch Youtube everyday and the reddish effect hurts my eyes. The blurry effect shows up in web browser and causes unreadable small fonts.

For those who want to flash GSI ROM please read below:
Please be warned before doing this: 1. all your data will be lost 2. your warrantee may be void.

Requirements:

  1. Download Android adb driver here or here.
  2. Download Android platform tool here.
  3. I used this GSI ROM for flashing, but you can google search other GSI ROMs. There are many other GSI ROMs. You need to look for ARM64 and A/B partition type. You will notice these in the file naming conventions.

Actually you need to unlock bootloader for doing this. But Hipad Pro is unlocked by default.

Follow these tutorials for flashing GSI ROM without TWRP here and here.

1 Like

I’m not able to flash the GSI Rom since the bootloader on my device is locked. I’ve tried to unlock it on fastboot (either with “oem unlock” or “flashing unlock”), but it returns fail everytime, even with the “Oem unlocking” enabled on developer settings

What platform tool version are you using?
Try fastboot oem unlocking
Please type this command in bootloader to check oem unlock status:
fastboot oem device-info Mine shows true for Device unlocked info.
01 device info
and post the result here.

I am not sure about the Chuwi policies for Hipad Pro. It may be possible that different models for different market zones have different OEM policies.

Mine is unlocked by default from the factory or from the seller. The command that mine recognises is fastboot flashing unlock but it said error because the device is already unlocked.

If you still can’t unlock bootloader, you may need to wait for the tool from Chuwi for unlocking your device. Hipad Pro is Qualcomm Snapdragon device. The developer team need to develop flash tools and unlock tools by themselves. This may take quite some time to wait if your device is not unlocked by default.


I’m using version r31.0.3, still no luck with fastboot oem unlocking. Guess i’ll have to wait. Thanks for your support

I am sorry to hear that. I found this tutorial on how to unlock Hipad here using a tool downloadable here. But the tool may work for Hipad Pro since it works for Qualcomm devices as well.
Remark: I am not the creator of this tool and not responsible for any damages that may happen. Please scan virus or do whatever you can to ensure that the tool is safe for use.

This tutorial shows how to unlock bootloader for usual Android device here. If you cannot succeed with any of the above methods, you need to wait for unlock tool from Chuwi.

This is the example of some Android devices that need official unlock tool to unlock bootloader here.

Hope one of these will work for you.

Hello!

Probably it could be done by setting specific value via SetEdit. I checked, there is no specific key for screen blur on Chuwi firmware, but probably it could be possible add that key name and it will work.

Could you please provide SetEdit screenshots with “Enable blurs” enabled and disabled? We could understand with key should be responsible for this

Hello friend,

I just realised SetEdit app the first time from your mention. Installed this app and searched for blur function already but could not find anywhere with SetEdit.

After testing a few times turning on/off for “Enable blurs”, this function just blur the background when there is another app or something overlaying. For example, when I pulled down status bar, this function blurred out the background. So I am not 100% sure now about this function is the main reason for blurring the overall UI in Stock ROM for Hipad Pro. So you may wanna look for other parameter(s) that may cause the blurry effect.

How about flashing GSI ROM on Hipad Pro? Have you tried this? After flashing GSI ROM, I don’t have problem with blurry effect anymore. Everything is super crisp as full HD now. According to DRM info check, my screen is at 1908 x 1212p with 500 nits. Not sure if there will be some variance of the screens across different market zones since I read many reviews about Hipad Pro with different screen resolutions.

Hi super, just wanted to congrats for all your time to searching how to fix this issue and help the community. I might try to do this flash during this week :)!

Did you notice any performance issues? or with this flash, everything else will work as before?

Thank you again.

Hi manuelbrunopt,

You’re welcome. Flashing GSI ROM took me about 30 minutes. The /system partition of Hipad Pro is quite different from the one of other tablets that I used to flash. After erasing system, I could not flash at the first attempt and was sweat since I don’t have Stock ROM to reinstall. Almost turned my Hipad Pro into a paper weight.

For the performance, everything works fine. I checked Widevine L1 still intact, all connection like Wifi, phone signal of dual sims, bluetooh and so on. The only thing that I am wondering is about charging capacity. When I was on Chuwi Stock system, I could charge at 2,500 mA max. But on GSI system, I could charge at around 2,200-2,300 mA max.

The display is very crisp now. And no reddish effect. Very happy after the new system installed. You will see the real beauty of the display after fixing these 2 issues.
By the way I don’t have Netflix account or any of these online channels like Disney+, HBO or so. So I don’t know how Widevine L1 works well after flashing GSI ROM. Hope you can test this L1 usage by watching 4K streaming of these channels after flashing GSI ROM.

1 Like

Super, again, thank you for your amazing info! Always ready to help the community here :)!
About your flash process, gosh! I will ready quite well all your steps, I really don’t want to screw up and I’m so keen to see the real beauty of the screen :)!
About the Streaming services, actually I have it, so as soon as I flash it, I will be able to share that :)!
Thank you again :)!

What’s wrong???

It probably mean the bootloader of your Hipad Pro is locked. Type in this command to check Device unocked status: fastboot oem device-info
If Device unlocked: false, you need to unlock your Hipad Pro first.

1 Like

I found a tutorial about unlocking bootloader here. This said:
After setting, this mode persists across reboots and factory data resets.
(After you enable OEM unlocking, you need to factory reset.)
Remark: Performing factory reset will erase all of your data in the device.

1 Like

Hi super, could you please record a video showing the tablet with new rom to see how different it looks? Thanks. If you could upload it to YouTube could be better

I tried to check the bootloader, it writes like this.Screenshot_2

maybe the tablet needs to be put into fastboot mode ???

Hi JOSHZ, Recording video from screen will not show the correct color and video codec will blur out the crispiness anyways. It’s best to see the different look on your Hipad Pro.

Before flashing GSI ROM, you need to unlock bootloader first. Otherwise all command lines to manipulate the system including all related partitions will not work.

1 Like

Super Hi again :)!
Two questions that turns out to my mind:

  1. This GSI comes with the Google application already installed? (e.g "PlayStore, Gmail, etc…)?
  2. Did you notice if now with this GSI the screen is all used? what I mean is…in many apps, you always size a black line on the camera side, and not completely on a full screen mode.

Thank you again for all your support for the community.