Flashed GSI ROM on HiPad Pro and fixed reddish and blurry effects

If so, it probably means your fastboot is not updated. Try download and use the updated fastboot tool from the link that I added in this thread.

Having fastboot v31.0.3 and sdk Manager from Android Studio shows that there is no update available for platform-tools.
I guess I can just wait for any news/updates from Chuwi :slight_smile:

I would share an idea about the blurry effect. Note that the idea is an assumption only.

Sometimes with a LCD screen that are not the proper resolution to be set nor the proper refresh rate, there is some wrong image.
Because the display informations are 1908 x 1212p (see post number 9, October the 2nd), may the bad image is due to this wrong setting?

Super, hello! Do you have a global firmware or a Chinese? Check if you can choose the Russian interface language? There is a version that the bootloader is unlocked on the Chinese firmware, and blocked on the global.

Hello Anathema,
I just checked as you mentioned and found Russian language in my system settings as shown below.

But I am not sure about which version of my firmware because I have flashed GSI ROM already. From my experiences, the system will apply all apps and settings from the ROM image being flashed. For example, my K30 5G flashed Chinese firmware with only English and Chinese and no GAPPS but after getting flashed MIUI.eu ROM, the system has GAPPS and all languages. This also happens for flashing GSI ROMs.
On the other thread, gibus’s Hipad Pro has been unlocked as well after claimed for the new one. Please check out this thread here.

By the way I just noticed about charging at 3,000 mA now as shown below. Not sure if this charging speed happens on every other Hipad Pro with stock firmware?

1 Like

Thanks for answer. It remains unclear why some have a locked bootloader and some do not. By way, posted the firmware

2 Likes

You’re welcome. My guess is the first batch of Hipad Pro is still locked but the later batches are now unlocked so the customers who claim the new ones will receive the unlocked devices.

Anyways I am glad that you shared the stock firmware with flash tools. I believe that by flashing the stock firmware will also unlock bootloader of Hipad Pro at the same time. I translated the manual file inside the .zip flash tools file into English version. Welcome for anyone to download here.

I would like to create another thread for flashing stock firmware. So it will be easier to google search later on.

1 Like

Thank you Super!
After the update (“Wireless update” in the HiPad Pro menu, then a “factory reset” (wipe data, …)) my new Hipad Pro is working properly, except a little blurry effect.
The little blurry effect is like a wrong character policy is used on the main page. When I walk through menus, this blurry effect is less. Note that I am in dark mode.

You’re welcome.

That’s the same as what I experienced when on Chuwi Stock system.
BTW I found an adb command to set resolution to FHD as you metioned. This link shows the command to set resolution via adb shell here.
adb shell wm size 1212x1940
adb shell wm density 320
According to Device info app, my display resolution is at 1940 x 1212 pixels and density is at 320 dpi.
If these command lines work, you don’t need to flash GSI ROM for fixing the blurry issue.

1 Like

Hi Super,

thanks again for all your help!

Just a question…so if I understood well to follow your last comment I should:

  • connect my tablet on the computer
  • turn on developer option
  • open the SDK Tool
  • put my tablet on the fastboot mode
  • write down the below commands:
    adb shell wm size 1212x1940 (this is on the correct order…or should be 1940x1221)?
    adb shell wm density 320
    reboot the tablet

Can you please confirm in order for everyone do it if they desire it.
Please feel free to add any comments ;)! I would appreciate it.

Thank you

Hi manuelbrunopt,

adb shell can be used during the system running on. When you boot up the system, you can use adb command lines with adb fastboot platform tool by connecting your Hipad Pro to PC.
From the example of adb command line to set up FHD resolution, it’s as that order (1212x1940).
After applying the adb command lines, reboot once and see if the blurry effect is gone. If yes, that should be the solution for the blurry issue which we are looking for.

1 Like

Hey super, I just tried now and… looks like the blurry effect is kind of gone :smiley: !
To be honest I was already so used to the other effect that now, I couldn’t kind of compare the changes :P!
Even so…thank you so much, for solving already one issue…now the other one that drives me crazy is not having full screen mode on all the Apps, Gosh!

But is already and improvment, thanks to you!!

1 Like

There is a way to compare the different between lower resolution and higher resolution setups. You can enter these command lines in adb:
adb shell wm size 720x1280
adb shell wm density 160
Reboot once and see the lower resolution look.
Set the resolution back to FHD by these command lines in adb:
adb shell wm size 1212x1940
adb shell wm density 320
Reboot once and see the higher resolution look.

The icons of the UI will be easily observed for blurry issue. If these adb command lines really work, I will create a thread about fixing blurry issue.

1 Like

Super I was having a look, and at least from the interface, like icons it still has some kind of blurry thing on it…plus I realized also on the images from the Google search, all the images look blurry and not clean :(!
But from the Google Chrome and from Netflix “looks” better, but I can really tell you that was chances or not so well :(!

Maybe someone can try and have a different perception, because this procedures are quite easy to execute!

1 Like

Another way to prove the lower resolution and higher resolution settings work is to screen capture and see the pixel resolution images of lower resolution setting and higher resolution setting. If the screenshots of lower and higher resolution settings correspond to the sizes that were set by adb command lines, then there may be chance of the blurry issue from low resolution of icons that do not match FHD display.

Hi super,

I tried and everything still looks the same :(!

Btw…do you have the stylus (pen)? I saw on the web, that with the current system then pen has a lag when you are drawing…do you know if happens the same with the GSI room?

Thank you in advance for your time.

When adb commands are used, the change is immediatly updated to the screen. It is simple to observe the result by making a big change with the resolution, ie by a change from 1940 to 720 and revert.
Thus, I don’t think it is necessary to reboot the tablet.
And because the change is immediatly applied, does the new setting is preserved after a reboot?

I have tried to flash the boot.img patched with magisk using qfil but the system didn’t boot, says the system is corrupt. Flashed the original boot.img and the tablet is working again. My last hope is trying to flash an unlocked boot.img

1 Like

Does anyone have an unlocked boot.img to share?

There is a user who returned his Hipad Pro and got the new one with unlocked bootloader. But after he updated firmware via OTA update, his device got locked.