Gemibook how to bootstrap from a USB drive?

Hello,
I need to restart my PC from a USB card instead of the C: drive, but I don’t know how to do it: I tried pressing the F8 key during the boot, as I read on the internet, but the selection menu doesn’t appears and the PC restarts normally.
I tried to enter the UEFI (BIOS), in the BOOT section, but I can’t find how to set booting from USB.
Can anyone help me ?
Thank you and greetings
Ermanno

Try to press Ecs or F7.
You can choose boot device in “boot override”

Hi Max,
thank you; pressing the F7 during the bootstrap key has no effect, Esc open the BIOS window, but in the Save & Exit section, under Boot Override I only seee two options:

Windows Boot Manager (P1: W800S 512GB SSD)
Windows Recover

and no other option relating to USB or SD card.
On my very old laptop the F2 key open a window that let me choose the boot sequence, but on Gemibook F2 has no effect.
Any other idea ?
Ermanno

You can try to press all F keys also try fn+F combination.
Make sure you have uefi boot usb, this bios may have problem with legacy boot.

Is your USB bootable? How ? In the bios you have to enable legacy boot.

Enter in the Boot menu.
Just put on the first option and press ENTER, then choose “USB…”

Make sure your bootable USB drive is connected. Restart and press the ‘Delete’ key over & over during boot-up to enter BOIS. It should show up under the ‘Boot’ tab. Choose it and press ‘Fn’ and ‘F4’ to exit into the USB drive.