GemiBook XPro Secure Boot setting cannot be disabled again

Hello, I bought GemiBook XPro (N100) and noticed that Secure Boot is disabled. I enabled the Secure Boot setting in UEFI settings, and Windows 11 can’t boot with the following message.

Secure Boot violation
Invalid signature detected. Check Secure Boot Policy in Setup

I tried to change the setting back to Disabled, but I could not change the setting. In UEFI menu, proceed to Security tab, Secure Boot is fixed to [Enabled] and could not change to [Disabled].
I could press F3 key to load optimized value, but when I save it and exit, the setting returns to Enabled again.

Does someone have any ideas to disable or reset the Secure Boot setting?

If I disassemble the PC and removing the battery, will the settings be restored?


I opened the back cover of the PC, and removed the battery from the main board. After waiting for a couple of minutes, the UEFI settings were restored to the initial value. Windows 11 was now booting. Thanks!

I didn’t experience that problem when I enabled my secure boot on my Gemibook Xpro. What I did before enabling the secure boot is to change the Secure Boot Mode from “Custom” to “Standard”. With that on, enabling and disabling secure boot didn’t have any issues in booting to Windows 11. Hope this helps.