Herobox 2023 N100, no C8 package power, undervolt lock


I bought a Chuwi Herobox 2023 N100 and trying to tweak it the last couple of days. First thing: The included fan is a total joke, and runs always at 100% sounding like a jet engine, even the CPU is just at 44°C. Not sure what Chuwi thought of this. This is not acceptable. I tried to set in bios (enter via F7) other fan speeds, but it doesnt seem to work. So I just opened the box and disconnected the fan, and set a maximum power draw of 8W in bios, or via ThrottleStop for both PL1 and PL2, and also activated throttle PROCHOT tripple point in bios and set it to 95°c, problem solved. The box is now 100% silent, and the included heat sink can totally “tank” it with max power draw of 8W. Even with fan off, the CPU wont go higher than around 80°c with 8W load.

Back to main question:

Two issues here. The CPU cant enter C8 power state for the package it seems for whatever reason under idle. This causes a permanent power waste of around 2.5w under idle, shown in ThrottleStop under Windows 11. Other reporting the same here with different Chuwi laptop with N100:

Die anyone on here was able to configure their Chuwi device with N100 to reach C8 package power and go lower than 2.5w idle for the package? I am 99% sure this is a driver issue or bios issue.

Would be nice if Chuwi could look into this to see if a bios update could solve this. Normally Intel CPUs can go low as C8 or even C10 and reach around 0.5w for the package. That is 2w of heat waste for nothing.

Last question: Anyone able to unlock undervolt for their Chuwi N100 device? I was not able so far, the flag for Undervolt Lock seems to be missing in the Chuwi bios/Uefi. I read somewhere that it might be possible to flip the flag with a tool called AMISCE (AMI Setup Control Environment) utility v5.03 or 5.05, but not sure if it works for the Chuwi Herobox. Anyone tried it? As posted on here for another N100 device: