Hi10 x Ghosting

Hi! I’ve seen some other members having this same problem, but no real solution. How do I fix my brand new Chuwi Hi10 x? It keeps “clicking” on random spots on the screen. VERY frustrating. I can’t even type this topic, bcs it keeps moving the cursor!!!

Roberto, if it’s linked to the over-sensitive touchpad gestures, then please try the instructions in this video. I had a similar problem to you, then I found this video and it worked for me: https://www.youtube.com/watch?v=UvMDXwpLMGw

The phantom touch started before my keyboard and touchpad came in the mail

HI, i have the same issue with touchscreen, did you found any solution?


Best Regards!

Not yet sorry. I’m going to write customer svc directly I guess.

hi, i have launched Hi10 X return process and ordered a HP Probook X360 as replacement.
good luck!


Any thoughts on this? It’s the digitizer I believe, that’s randomly picking up ghost signals. Any solutions?

I have this issue from months. No solutions…It is very annoying. Probably It is an hardware issue.

same thing here! Used 2 different dock keyboards, same thing!! Random clicks one after another… touchpad unusable!!
Please fix !!!

Try using a different charger as it can introduce “noise” into the battery that produces those ghosting.

I’m using on battery and still the same.

I will try it. Thank you

Maybe @manonegra222 means that you have to use a different charger when you need to charge it. The noise is introduced during the charging, and it remains until the battery is empty (also if you use it on battery)

Totally ruins the experience… Using an external keyboard with touchpad works fine…

It is not very easy use a different charger :sweat_smile:

You guys, I may have a theory… But I need you to test it. Can you try not to use hipen for a while and see if the random clicks still occur? I noticed that after i use my hipen6 the touchpad goes crazy…

I take it back… after long hours of testing, the clicks are back on both keyboards… only right click and some movement, but mainly right click one after another infinitely…

I can’t seem to find out why it occurs…