Hi10 XR Cursor Problems


I bought tablet Hi10 XR, but there is a problem with the pen’s cursor.

At first the cursor was lagging behind the place of the pen and then it was slowly going under it, which was not a problem only when the pen was touching the screen - it was not lagging, it was working perfectly, except for the rest of the time, when the pen was not touching the display.

In the system’s pen settings menu I didn’t find any option that was allowing the cursor to act like that, so I’m guessing there are installed wrong or old drivers for the pen. So I tried updating them and the cursor was no longer lagging behind and coming back - it was only moving at around 5cm distance away from the pen, no more going back towards it.
Then I found out, that the pen problem is the same as using finger, so I don’t think the problem is with the pen anymore.
The touchpad and an external mouse, connected trough USB to the keyboard was the only properly working option.

I tried bringing the system back to it’s default settings, but the cursor is double the distance away from the pen’s location (still no lagging and slow coming back to the pen).
I updated every single driver to it’s newest version – same problem.
I tried calibrating the pen several times – the problem still exists.

Right now the cursor, moved by the pen, is going in random directions, while when the display is being touched with finger – it stays on the bottom right (before that it was acting exactly like the pen).

Also - I know, that the XR version is the newest version from the Hi10 series (there isn’t even a category for this version in this forum), but where can I find the official released drivers, if there are any?
Since I saw in several reviews, that the cursor is moving a little bit behind the pen’s location, then coming back under it, it seems to me, that that was the design itself, but I think that that’s a pretty stupid detail, because when at first I tried to click some buttons, the cursor clicked where it was still behind and then coming back under the pen, which was right above where I wanted to click…
Aren’t graphic tablets supossed to be precise?

What I’m experiencing - is it a fixable problem, or a defect?
Can anyone find any logic in this situation?
What’s going on? What can I do?


I got the system back to default settings again.
This file has “migrated” by itself and it just doesn’t want to install itself, I already tried like 6 times before the default settings.


Check the status of your touch screen device by device manager.
(Human Interface Device -> HID-compliant touch screen)
If the device doesn’t work, it’s probably a fault. pls. contact seller or CHUWI support.



In my Hi10X, touch screen and stylus pen are working properly with Microsoft generic drivers.

(this is the case of stylus pen, touch screen is the same)

Driver for them are specified in [HID_RAW_Inst.NT] section ( input.inf ).

; Raw Devices (do nothing)
AddProperty = HID_Raw_Inst.AddProp.NT


AddService = ,%SPSVCINST_ASSOCSERVICE% ; null service install

So, no device-specific drivers required.

Touch screen(+ stylus pen) in Hi10X is GXTP7386(or GDIX1002) manufactured by Goodix.

Device HID\GXTP7386&Col02\5&927a7d0&0&0001 was not migrated due to partial or ambiguous match.

Last Device Instance Id: HID\GDIX1002&Col04\5&359347b8&0&0003
Class Guid: {745a17a0-74d3-11d0-b6fe-00a0c90f57da}
Location Path:
Migration Rank: 0xF000FC00FFFFF100
Present: true
Status: 0xC0000451

They are working properly under the condition above.
I wrote for this might help someone in trouble with these devices.

(some linux distributions recognize gdix1002, so they may possibly be used as a pointing device, I’m not sure)