Hi10X wont boot due to charging at wrong port

I recently bought a hi10x and started using it, I had it powered on and I tried to charge but accidentally plug the charger into the data port. Now it won’t boot up. I tried holding power key for couple 10 seconds and only a red led light shows up and then nothing. Any ideas?

Try this:

Tried already, the bios doesn’t show up

Since you have just bought the device, I would recommend to contact the warranty service.
If you don’t have such a possibility, you need to check the battery voltage, check the resistance of the components near the type-c connector, these components most likely support maximum 6V and could burn out.

It won’t boot even with charger connected to the right USB-port?
It’s easy to make a mistake connecting to the wrong USB-C, it will be really weird that Chuwi does not take care of this kind of event.

1 Like

turn laptop on to boot up, but keep pressing the delete button, till you get to the CMOS screen.

Thanks for the tip. I would never have thought of that. I’m forever plugging things in by feel.

Out of curiosity , I tried plugging the charger into the data-only port , just to see what happens . Result is , nothing happened . The tablet is still charging and working just like before .
Then I tested plugging the chuwi 12V charger to my android phones . And the result , nothing happened , the phones simply won’t charge with the chuwi charger . And both phones are still working .
I’ve also tested with 2 power banks , no damage resulted.
I’m sure the engineers have also tested these scenarios .

1 Like

I am very suprised, and stand corrected. From what I have read of the USB-PD spec, I would have thought damage would result. Thank you.