HiPad Pro no firmware and what is attestation key

Hi I want to get root access on my new HiPad Pro but before I try, I’d like to have the original firmware just incase I stuff something up and need to flash it. However I cant find any firmware for it. HiPad Pro CWI526 (HiPad PKY1H211202147).
Also, what is this Attestation Key? I noticed it in the settings under “about” and was wondering if that would affect me unlocking the bootloader?

Hello, you can contact service@chuwi.com to get the key

Anyways chuwi Service never Help us. I have more than 6 months waiting for a root method for my Chuwi Hipad Pro with Snapdragon Processor and also how to unlock it But they just keep saying stupid things and never helped me. This is the worst company of the entire world.

Customer Service ls garbage for them.

I contacted Chuwi service and they provided me with a key to unlock the bootloader which is based upon the country where I reside.
The only problem is they didnt provide me with any instructions on how or where to use it.
Im going to try a few commands using fastboot and try input the key to unlock verity boot.
If you know how the key works, Id appreciate some assistance. Ive also asked Chuwi service if they could send me some instructions for using the key. I’m just awaiting a response.

Hi Is your Chuwi Hipad Pro equiped with a Snapdragon Processor?

No I’ve got the MTK model. Ive seen online that for the snapdragon version, you use Xiaomi’s tools and unlock procedures. See this method
https://m.youtube.com/watch?v=Ey4sfnJzFOQ

But start by checking this post
https://forum.chuwi.com/t/unlock-bootloader-for-hipad-pro/27329

Hello,
You are lucky getting mediatek version of Hipad Pro. It’s much easier to unlock bootloader than the Qualcomm version. Try this tutorial at 4th method. I got Qualcomm version of Hipad Pro and still have no idea how to unlock bootloader. Luckily mine is unlocked by default and flashed GSI ROMs already.

BTW there are a number of unlocking commands in fastboot mode. But not sure which unlocking commands your Hipad Pro got implemented. If the command in the above tutorial does not work, you can try this command here. My Qualcomm version of Hipad Pro got fastboot flashing unlock working. Your Mediatek device may be different. If you can successfully unlock bootloader, please share your method.

It’s weird… I got the key from chuwi service to unlock the bootloader and I didnt even need it. I tried fastboot flashing get_unlock_ability and it come up with error unknown command. so I went through the standard unlocking commands fastboot flashing unlock and fastboot oem unlock and that didnt work. I tried fastboot flashing critical unlock and sure enough, the option came up on the tablet screen “do you wish to unlock the bootloader volume + yes and volume - no” so I pushed up expecting it to ask for the unlock key and nothing, it then left me at the menu for reboot/recovery/bootloader so I rebooted and it proceeded to erase everything and booted up. It took a long time but did boot up again and the bootloader is unlocked now.

1 Like

Can you tell me more about unlocking?

Glad that you can successfully unlock bootloader for your Hipad Pro.
fastboot flashing critical_unlock

I had 3 Mediatek devices: 1.Teclast M30 Pro 2.Teclast T30 3.Alldocube iPlay 30 Pro
All of them can be unlocked bootloader easily. Unisoc devices are a bit harder to unlock by using Hovatek tool. I had Alldocube iPlay 20 Pro and Teclast M40. Used their tool to unlock bootloader. Most Qualcomm devices require more specific methods to unlock bootloader. Mostly the unlock tools have to be developed by their own manufacturers. And may vary depending on each variant edition of the device models. Quite sophitcated to unlock Qualcomm devices.

Anyways congratulation! you can try root your device or flash GSI ROM that suits your favors. I explain how to flash GSI ROM here. There are many GSI ROMs that you can google on the internet.

Is your device Mediatek version of Hipad Pro? If yes, the unlock command is fastboot flashing critical unlock.

no i have a qualcomm snapdragon

There is no method to unlock bootloader for Qualcomm version of Hipad Pro as of now. This needs Chuwi to develop unlock tool. But it seems they won’t.

Is not necessary to develop an unlock tool, it only requieres that they give us a Firmware with unlocked bootloader.

1 Like

I hope so too. But usually users will take their own risks to unlock bootloader and be warned that their devices’s warrantee will be void.
If Chuwi release firmware with unlocked bootloader, that means they will have to take risk if users do something wrong to the system. That’s why usual Android device manufacturers will let users to take risk to unlock bootloader.
Anyways Chuwi have changed Hipad Pro to Mediatek. There will be no support for Qualcomm model anymore. :cry:

That´s the reason why I will never Purchase a Chuwi Product again I feel cheated and ignored as a customer. All their products are faulty or have problems with software. COMPANY SHIT.