Identifying the burnt component

So, looking for a kind person to help who doesn’t mind, or already has opened their minibook.

I have a minibook, for around 6 months, and suddenly it won’t power on, and won’t charge. Same without battery connected.

The problem has been traced to a ‘popped’ power regulating transistor on the board.

This could be replaced to fix the machine, however as it is blown, the markings on the component are not visible to identify it.

Its a long shot but if there is anyone that has already photographed the back of their motherboard, or is willing to do so, I could identify the replacement part needed.

I’ve included a pic of the board below with the blown part highlighted. I think I can make out EJ but not the start of the label.

Help massively appreciated, without it the machine is a write off.

Thanks in advance.

2 Likes

I have the exact same problem! (no charging and not able to boot, and a broken chip) The chip has a ‘SEJ’ marking on it and is a 3.6 volt linear regulator chip; TEXAS INSTRUMENTS TPS709 ( TPS70936DBVT to be exact). Couple months ago the chip wasn’t on stock, thus I have not replaced the chip yet.

I do question though what caused the chip to break. Replacing it might cause it will break again over time.

1 Like

Thanks Theo. I did think I had managed to identify it from the partial, and ended up ordering a replacement, via eBay as only stock I could actually find.

That said I had thought it the TPS70936DBVR as suppose to the TPS70936DBVT, so perhaps I’ve misordered. They’re inexpensive so not a problem to reorder the other. I too question the cause, maybe just a cheap version of the chip?

Both chips are the same; the difference between the ‘T’ and the ‘R’ is just in what package they are shipped when they leaving the TI factory (full reel or strip, which does not matter at all when you just order a few of these chips as within the reel/strip the same component is packed.)
You were able to source the component direct at TI or any official reseller?

No, absolutely not, it seems everyone is out of stock, with none expected for some time. I’m expecting I’ll receive a low quality component, which may have been the issue in the first place.

It’s my partners laptop, but I think once repaired we will probably sell it. There just seems to be too many common problems with the minibook

There are indeed al lot of issues with the design, but this is my first issue I can’t solve, work around or improve.

According to your picture your chip looks quite damaged; and most likely some smoke must be coming from the laptop when the chip broke. Have you seen any smoke in the past from the Minibook? And if so, what did you do when it happened?

I did connect my Minibook to another universal usb-c charger I used to use for my other (Lenovo) notebook and the Minibook for a while. I did connect the charger to the Minibook, then connected the charger to the AC-mains voltage, and at that point I instantly had a bit of smoke coming from the Minibook near the TPS chip.
The Minibook did seems to work afterwards for quite some time (few months), although the battery only could be charged when the Minibook was on. (thus with a flat battery the Minibook could not switch on, and thus could not be charged… I had to open the Minibook nd connect teh battery direct to a li-ion charger)
Remarkable was that since that the Minibook requires 19 volt to charge… Till it began to had booting issues; occasionally it couldn’t find the M2 SSD, then it never could find the SSD and often I could not enter the BIOS, and now It’s just a dead brick…

I never saw any smoke, it must have happened when unattended. Left it charging, the next day it wouldn’t power on.

However I was already having an issue whereby it would only charge when the laptop was on, so perhaps something was already damaged.

I am still waiting on the new chips to arrive, so once I’ve swapped the voltage regulator I’ll let you know how it goes

@Farmer333 Thank you so much for posting a photo of the mainboard backside!
Could you give any further instructions on disassembling MiniBook, i.e. will I need to apply new thermal glue to the heatsink, or does it all come off as one piece?

My problem is that finally, MiniBook is no longer charging any battery at all; I’ve had multiple batteries over the last years, I think this is #4, after the previous ones got damaged (i.e. disbalanced, with one cell directly touching the main heatsink etc.), and they got stuck at 80%, re-plugging often worked etc. I’ve done it all multiple times… I also switched to a 20W PD charger which only supplies 12V, since I believe this would cause less stress on the battery and / or balancer circuit.

But now everything is different: The PD-analyzer tells me MiniBook is no longer making the switch from 5V to 12V or 20V requested from the charger, there is no LED indication when plugging a charger (However when the battery is detached, plugging the charger will result in orange flashing LED, but staying at 5V input).

I’ve ordered a replacement EJ898H, still waiting for it to arrive, I hope this might be the issue here.

In the meantime, I am wondering if it might work to directly force 12V to the USB VBUS pins, or if this would damage MiniBook? (i.e. does it only survive the 12V after requesting it, or maybe the charger itself is damaged, so it doesn’t make the switch to protect itself!?)

Apart from that, MiniBook is perfectly working, it even shows the correct battery gauge and estimated runtime, it’s just a little annoying for travelling, when the battery can only be charged by an external charger :joy: :innocent:

Any further input on the charging circuitry is appreciated!

Thanks, Sebastian

A little update on the not-charging MiniBook: I have removed the mainboard, but could not see any damage to components - even EJ898H looked fine. Since my replacement chip arrived, the EJ898H was changed anyways, but no difference! So this part was not faulty.
I checked with thermal camera, there’s nothing overheating, just the SEJ 3.6V regulator going somewhere around 40°C, so nothing to worry.

VCC for EJ898H is around 0.42V with battery attached, and 3.3V when the charger is plugged in (though charging voltage remains at 5V).
So eventually, I dared to see what happens when the voltage is increased on the USB port without prior negotiation: Turns out, it would charge just fine a couple seconds after a voltage greater than somewhere around 11V is applied =)

So despite the EJ898H not fixing it, I could now build a 12V-force-feed cable to charge it. Still wondering about the cause though.
I see that there is a 24C04 512 bytes EEPROM (between Type-C plug and display connector) directly attached to the I2C pins of EJ898H. I sniffed the i2c traffic, and it seems to read only the first 4 and also 4 out of the last 5 bytes of the EEPROM (0xA0 0x01 0x9F 0x00 at offset 0x00 from i2c address 0x50 and 0x06 0x06 0x06 0x20 at 0xFB of i2c address 0x51).
I assume no one has an idea what they mean? maybe configuration in EEPROM is broken? There is also data read from i2c address 0x60 continuously, probably temperature monitor or something;
or maybe 0x60 is just EJ898H in slave mode, when it is polled by EC? EJ898H also has connections to a shunt resistor for the Type-C VBUS line, not sure if this is for the charging system to be reported to the operating system (but probably it is just for over-current protection / role detection within the chip itself).
The data is infinitely repetitive and seems to be the same whether a real PD charger (i.e. no charging) or 12V-force charging is applied.

I only found this schematic from another laptop, containing EJ898H on page 51:
https://bugs.freedesktop.org/attachment.cgi?id=144392

One more thing I noticed: a tiny black component has fallen off between the display connector, EEPROM and the inductor labeled 4R7.
The PCB marking 7 is at the bottom right of that component, does anyone have a picture from that side of the PCB, around the EEPROM?
That component is in parallel to a capacitor and the pins going to the flat cable connector, but maybe it is still somehow related to charging as well? Could be a diode, or maybe over-voltage protection etc…

Any help identifying that component is highly appreciated :slightly_smiling_face: