Is there a way to fix the battery level bug at home?

The battery of my Minibook always reports a charge level of 100% while discharging, until the laptop shuts off for lack of power. While charging it again, the charge level starts correctly at 0% or 1%, but rises far too quickly to 100%, even though the battery is clearly still charging. (This I measured with a pluggable power meter.)

The behaviour appears similar to what is described in this thread:

But the proposed solution there (completely dis- and recharging the battery repeatedly) is not having an effect for me. Is there anything else I can try?

Chuwi support suggested I send the device in for repair, but I’m using it as my main computer, so that would be a hassle.

hate to do a ‘me too’, but I am having the same effect. is there a possibility of an updated bios that could fix this?

Install the “battery bar”
After discharging the battery, try to fully charge the battery once again.

https://batterybarpro.com/basic.php

Update on my situation:

  • At some point my battery started behaving differently. Instead of staying at 100% all the time, now the status very quickly drops to 0% after disconnecting from the charger. This is annoying as it triggers an automatic poweroff on my system, but apart from that, the battery is still fine: I can reboot the computer and use it at 0% for hours.

  • Chuwi agreed via email to send me a replacement battery for me to install myself without voiding the warranty (instead of having me send in the laptop for repair), I only had to pay for shipping (which I did not try to contest). This was one month ago and they haven’t shipped it yet, but they are still responsive via email and stand by their promise to send it – I guess that they are having a production shortage.

Another update: Shortly after my last post (but probably not causally related, as I had also emailed Chuwi around the same time), Chuwi withdrew their offer of sending me a replacement battery and refunded the shipping cost. I’m not happy about that.

Next thing I tried, inspired by some other post on this forum, was to open up the Minibook (thankfully very easy, just screwed shut) and disconnect the battery plug for a few seconds. This worked as a temporary fix: The battery behaved almost flawlessly for a few days, even showing the correct levels. By now it is back to showing 100% all the time, but at least it is not randomly shutting down the system any more.

Chuwi sent my a battery for replace few days ago. And it works so far so good.
Maybe I live in China so I can get it easily.
During the Corona Virus all over the world I think they have to deal with the shipment method overseas

That’s good to hear! Maybe I’ll have better luck in half a year (hoping the pandemic situation will habe improved by then).

Mine is the same. Shows 90 odd percent for ages then the device suddenly turns off with zero power???