Linux audio on the HI 10 X

Hi, need to use linux on the HI 10 X. Tried recent live distros (ubuntu 21.04, manjaro 210519). Everything seems more or less fine:

  • screen rotation does not work in auto mode (but works in manual one);
  • WIFI works
  • Bluetooth works
  • PEN works with some glitches
  • etc.

Big showstopper is that audio does not work. Only hdmi audio outputs are recognized, no regular audio directed to the internal speakers or the headphones.

  • Has anyone succeeded making audio work in linux on this tablet?
  • Does anyone know at least what the actual audio CODEC is?
  • Is it necessary to have some GPIO tuned to get the audio working as it was the case in some previous HI 10 tablets?

I haven’t tried linux on the Hi 10 X (oddly, for me)… but I used to use OpenSUSE Tumbleweed on the Hi 10 Air, and everything was working perfectly. They are different chipsets so it may be the same story, but as a bleeding edge rolling distro you’re more likely to have the latest packages & kernels than Ubuntu (I’ve never used Manjaro).

It may be worth giving OpenSUSE Tumbleweed a try to see if there’s any improvement. If not, then post again, and we can try to get it working. :slight_smile:

Your suggestion to try a very up to date distro is in fact the reason why I tried Manjaro that is rolling, similarly to OpenSUSE Tumbleweed. I have tried with a ‘snapshot’ dated 21/05/19, only a week ago. I’ll try with Tumbleweed as well and report back… but it is unclear to me if I can expect significant changes wrt Manjaro.

My biggest concern right now is that I do not even know how to approach the issue. To the best of my understanding, the Intel SST audio (that is advertised for the machine) driver takes advantage of specific CODEC chips and I cannot even identify the one that is being used in the machine (whether it is the bytcrrt5651 that was adopted for the cherry trail Hi10s or what).

From windows I cannot get any hint and any help in that would be welcome.

I’ve just fired up my Hi10XR (I only use it during the winter). Windows 10 is listing it as a Realtek HD Audio for the speakers & headphones. The intel audio device is for the audio on the HDMI cable. Looking at the events tab in device manager, it revealed HDAUDIO\FUNC_­01&­VEN_­10EC&­DEV_­0269 as the audio device. Hopefully, that might steer you in the right direction. :slight_smile:

The reason I suggested OpenSUSE Tumbleweed is for the excellent YAST Hardware Information tool, which might shine some light on the problem, if audio isn’t working.

Thanks for your test! As a matter of fact, the hardware looks different!

I do not get any mention to Realtek HD audio, only Intel SST. I’ll try to grab the VEN (vendor?) and DEV (device?) IDs from windows to see if they can be helpful.

And try tumbleweed of course!

Tested OpenSUSE Tumbleweed, without any significant change.

I still get “dummy output” only for sound.

It’s odd that you don’t have 2 audio devices listed in Win10. Mine is the Hi10XR version, but afaik the only difference is the N4120 CPU on the XR vs the N4100 CPU on the X, but I could be wrong.

Good luck! :slight_smile:

I do indeed have 2 audio devices in windows. One of them is for the HDMI and the other one, I believe, for the regular speakers+headphones audio. The thing is that both are presented as Intel SST, with the second one carrying the acronym OED (whose meaning is unknown to me). The second is clearly the one to which windows shows mic+speakers being attached to.

My problem is that I fail to recognize what this second device actually is, in order to look for linux support for it (sof firmware, maybe or UCM files). The device codes are 3198, 0222 and AE34. And for all of them the vendor code is 8086 (intel).

… and it looks like there are 2 different types of HI10X. Mine is equipped with an N4210 CPU just like the XR. But evidently also with a different audio compartment from the XR.

I wonder if it is only a matter of time for proper audio support to come.

Not having much luck with google-fu, but reading one post did put a question into my head. Are you dual-booting on the Hi10X, and if so do you have ‘Turn on fast start-up’ ticked in the power settings on win10? That fast start-up can cause havoc with some devices when dual booting linux.

The Intel SST seems to be used in a lot of NUC devices, and there are plenty of threads about problems with drivers in Win10, but nothing obvious in linux land.

No, that is not the issue, not dual booting. Linux only. Bug open at [BUG] No local devices (speakers/headphones) on N4120 tablet (Chuwi Hi10X) · Issue #2955 · thesofproject/linux · GitHub.

Real issues here are:

  1. Chuwi made multiple versions of this item without changing the model name. Some have N4100, some have N4120, some have a realtek audio codec some have something else. Very very unfortunate for users IMHO. Having an “Hi 10X” and an “Hi 10X2” would have been more than enough to save all these issues. You read a review for the model, you get the impression that things should work and then the device is different and things don’t.

  2. Some parts of the Bios/ACPI tables are not completely filled in, so from the machine itself it is impossible to determine what hardware is inside. For instance from the NHLT machine tables (https://01.org/sites/default/files/595976_intel_sst_nhlt.pdf) it looks like there is an I2S codec, but it is impossible to determine brand and model which would be helpful.

In any case thanks for all your help, this is very much appreciated.