Linux distro on minibook x?

I have fixed the wrongly rotated screen with this udev file. Just save it as /lib/udev/hwdb.d/61-sensor-MiniBookX, make sure you have iio-sensor-proxy installed and with screen-autorotate installed and activated the screen rotates always correctly.

Hi, in Deepin you can choose between two kernels. I used the newer one, a hwe 5.18 kernel. The only things I changed in the settings app were screen rotation and hibernation. I also installed tlp. S3 I have not tested it as I use hibernation. I did not have problems with the touchpad or with the keyboard. Interestingly the Nreal glasses work (as a secondary screen) direct from the USB C port.
For context, before Deepin I was using Ubuntu 22.04 with some 5.19 release candidate kernel so that the computer would shutdown, I also used hibernation because of the suspension issue. In Ubuntu, I did not had the keyboard problem but had the touchpad freezing issue.

1 Like

keep in mind that the only real issue is “ctrl” key getting “stuck” , as by default the “block touchpad while typing” is active, this would cause the touchpad to be unresponsive. This was what caused the touchpad to “malfunction”

The “ctrl” getting stuck was happening to a lot of people, its a minor issue, and happens rarely

Sadly this is not true for many, as not just the ctrl key gets “stuck” but any other key can and will get stuck, too. This is the only thing that prevented me from being able to actually use the Minibook X under Linux, as I personally can live without S3 sleep.

I tried all kinds of things, even adding two special kinds of tape between the keyboard ribbon cable and battery, compiling my own Kernel with keyboard input timings tweaked, but sadly nothing ever helped solve the issue for me. It seems to require a fix on the firmware level, and is not something that can be handled on our end. At least for those of us who sadly got the issue, as it does seem like not everyone has it.

It’s mostly Ctrl for me but I’ve had Shift stuck as well once or twice. Seems to happen when I do three-key shortcuts like Ctrl-Shift-Tab or Ctrl-Fn-PgDn, but not always. It’s just enough to be annoying.

I recently watched this video by Ben Eater on how keyboards work. Seems like the issue could be tracked down with a scope but mine is pretty basic and doesn’t have binary decoding so I don’t think that’s something I want to go through manually :slight_smile:

hello, i just bought chuwi minibook x and try install ubuntu 22.04. all feature works fine, except WiFi.

resume of my installation using this command :

inxi -Fxxxrz && rfkill list && iwconfig && mokutil --sb-state

result :

  Kernel: 5.19.0-41-generic x86_64 bits: 64 compiler: N/A
    Desktop: KDE Plasma 5.24.7 tk: Qt 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Ubuntu 22.04.2 LTS (Jammy Jellyfish)
  Type: Convertible System: CHUWI Innovation And (ShenZhen)
    product: MiniBook X v: N/A serial: <superuser required>
  Mobo: N/A model: N/A serial: <superuser required> UEFI: N/A
    v: ZW-BI-105-S105JWR210-JCB0A-101-I date: 01/13/2023
  ID-1: BAT0 charge: 28.9 Wh (100.0%) condition: 28.9/28.9 Wh (100.0%)
    volts: 8.7 min: N/A model: WB SR 1 WB Lion Battery type: Li-ion
    serial: <filter> status: Charging
  Info: quad core model: Intel Celeron N5100 bits: 64 type: MCP
    smt: <unsupported> arch: Tremont rev: 0 cache: L1: 256 KiB L2: 1.5 MiB
    L3: 4 MiB
  Speed (MHz): avg: 1004 high: 1100 min/max: 800/2800 cores: 1: 1100 2: 717
    3: 1100 4: 1100 bogomips: 8908
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel JasperLake [UHD Graphics] driver: i915 v: kernel ports:
    active: DSI-1 empty: DP-1 bus-ID: 00:02.0 chip-ID: 8086:4e61 class-ID: 0300
  Device-2: HYGD-220831-A Hy-Usb2.0-1 MIC type: USB driver: uvcvideo
    bus-ID: 1-7:3 chip-ID: 1b0a:2bc9 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting unloaded: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5")
    s-diag: 599mm (23.6")
  Monitor-1: DSI-1 res: 1920x1200 hz: 60 size: N/A modes: 1200x1920
  OpenGL: renderer: Mesa Intel UHD Graphics (JSL) v: 4.6 Mesa 22.2.5
    direct render: Yes
  Device-1: Intel driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
    chip-ID: 8086:4dc8 class-ID: 0403
  Device-2: HYGD-220831-A Hy-Usb2.0-1 MIC type: USB driver: uvcvideo
    bus-ID: 1-7:3 chip-ID: 1b0a:2bc9 class-ID: 0e02 serial: <filter>
  Sound Server-1: ALSA v: k5.19.0-41-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Wi-Fi 6 AX201 160MHz driver: iwlwifi
    v: iwlwifi-stack-public:master:9904:0e80336f bus-ID: 00:14.3
    chip-ID: 8086:4df0 class-ID: 0280
  IF-ID-1: enxc299414d779d state: unknown speed: -1 duplex: half
    mac: <filter>
  Device-1: Sony Ericsson Mobile AB G8441 (Xperia XZ1 Compact) [Tethering]
    type: USB driver: rndis_host v: kernel bus-ID: 1-2:5 chip-ID: 0fce:71f4
    class-ID: 0a00 serial: <filter>
  Device-2: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-8:4 chip-ID: 8087:0026 class-ID: e001
  Report: ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: no address: <filter>
  Local Storage: total: 476.94 GiB used: 25.03 GiB (5.2%)
  ID-1: /dev/nvme0n1 model: NS512GSSD530 size: 476.94 GiB speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: V0323A0 temp: 47.9 C scheme: GPT
  ID-1: / size: 467.89 GiB used: 25 GiB (5.3%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 511 MiB used: 31.3 MiB (6.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Packages: apt: 4055
  Active apt repos in: /etc/apt/sources.list
    1: deb jammy main restricted universe multiverse
    2: deb jammy-backports main restricted universe multiverse
    3: deb jammy partner
    4: deb jammy-security main restricted
    5: deb jammy-security universe
    6: deb jammy-security multiverse
    7: deb jammy-updates main restricted
    8: deb jammy-updates universe
    9: deb jammy-updates multiverse
  Active apt repos in: /etc/apt/sources.list.d/deadsnakes-ubuntu-ppa-jammy.list
    1: deb jammy main
  No active apt repos in: /etc/apt/sources.list.d/gnuradio-ubuntu-gnuradio-releases-jammy.list
  Active apt repos in: /etc/apt/sources.list.d/kismet.list
    1: deb jammy main
  Active apt repos in: /etc/apt/sources.list.d/mozillateam-ubuntu-ppa-jammy.list
    1: deb jammy main
  No active apt repos in: /etc/apt/sources.list.d/ondrej-ubuntu-php-jammy.list
  No active apt repos in: /etc/apt/sources.list.d/osmocom-latest.list
  No active apt repos in: /etc/apt/sources.list.d/softwareradiosystems-ubuntu-srsran-jammy.list
  Processes: 228 Uptime: 23m wakeups: 1 Memory: 11.44 GiB
  used: 2.05 GiB (17.9%) Init: systemd v: 249 runlevel: 5 Compilers:
  gcc: 11.3.0 alt: 11/12 Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.13
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
lo        no wireless extensions.

enxc299414d779d  no wireless extensions.

SecureBoot disabled
Platform is in Setup Mode

the main problem is:

  • dkms
  • backport-iwlwifi-dkms
  • iwlwifi
  • libbpf not detected while manual compile backport-iwlwifi

wifi detected is : Intel Wi-Fi 6 AX201 160MHz

anyone is success up the WiFi ? thankyou advance :pray:

With the upgrade to kernel 6.4 and the latest Linux firmwares the keyboard issue seems to have been resolved. At least I did not experience it anymore in the last three days of use.


Unfortunately not. I tried right away after your message with a fresh NixOS install running Kernel 6.4.2, and the problem is still there. The easiest way I’ve been able to get the problem to rear its head is to boot up a game of some kind and play just a little bit, as heat seems to increase the likeliness of it happening. Less than two minutes into a Xonotic session against bots and my entire keyboard stopped responding again, which is one of a few ways this issue exposes itself.

So unfortunate, as this device is completely unusable for me due to this issue :(.

2023 minibook X, I have debian 12 stable up and running, but it required the backport 6.4 kernel to recognize the wifi. Bluetooth not working.

Screen rotation after boot fixed as described at Debian On(/InstallingDebianOn/Chuwi/MiniBook): GRUB_CMDLINE_LINUX=fbcon=rotate:1 in grub config.

The big problem I’m having is the screen after suspend: top half is black, lower half is corrupted. It seems pretty random how many shutdown -r or -h 's it takes before it kicks back. Putting i915.enable_fbc=0 in the grub config doesn’t seem to be working.

Is the BIOS (mostly) unlocked on the 2023 model, by any chance? I’ve been fiddling a bit with SerialIO timing value tweaks to see if keyboard related woes might improve on my <2023 model. It’d be nice to see what values the 2023 model might be using out of the box, if at all possible.

@jibsaramnim Have you found any SerialIO settings which solve the issue with keyboard? Would you mind sharing it?

I have not yet, no. It’s an unfamiliar area for me so I’ve been trying to read up and poke around a bit. My hope would be that someone who doesn’t have this issue — or at the very least has it extremely rarely or with just one key for example — can share what their device’s settings are.

These values can be found by booting into the BIOS, then heading to the “Chipset” tab, select “PCH-IO Configuration”, then select “SerialIo Configuration.” In there you might first have to enable the (last) option called “SerialIO timing parameters” if it isn’t already, after which you can enter “Serial IO I2C0 Settings.”

In my case I’ve been testing with adjusting the several “Hold” values in there, though I am not sure if that really does anything beneficial to the keyboard problem. In my very basic testing it did feel like the problem was occuring less quickly, but it was still a matter of time before the keyboard would just sort of deadlock itself and nothing but sleep mode or a reboot would bring it back. Super annoying :(.

@jibsaramnim Thank you for answering and a tip. It seems to help a lot. I just multiplied arbitrarily all the values ‘default x10’ (as they are still a puzzle to me) and keyboard hasn’t stopped working so far. I got one time key stuck (“q”) but it is a lot less then in the past. The only drawback I can see, touchpad is more “sticky”, e.i. when scrolling with 2 fingers I have to wait a half of second when finished. Otherwise scrolling still happens with only 1 finger.
Maybe there is anyone with no issue with keyboard and can dump here the values?

That’s great to hear! I have been trying to read up on what these values represent exactly so I could be a little more logical in my approach, but so far I wasn’t really able to come to any definitive conclusions. I mostly only modified the “hold” values so far, and like you it at least felt like the keyboard got stuck less frequently, though it still got stuck eventually. The fact that it takes some time before you even get to a “stuck” keyboard makes testing this all the more challenging, as I don’t really have all day to fiddle around with a computer that’s supposed to just work in the first place :sweat_smile:

I suppose this might indicate that the values you’ve settled on right now are a bit too far on the high end. I also noticed that if I set the “hold” values to anything over 200, the trackpad won’t work at all. I seem to recall during one of my deeper dives to a part of the Linux Kernel that had a value roughly around there as a sort of cut-off, though I can’t find it again at the moment. At least I was able to consistently have the trackpad not work at all with values (a bit) over 200, and consistently work with values under 200.

I have not tried more extreme values (yet), as real life duties have taken over the rest of my week again, but the fact that you also seem to have seemingly better results so far gives me great hope that we might still actually be able to get to a good solution. I really hope we’ll be able to find more consistently good numbers soon :).

not sure? (just a humble linux end-user here)

Hi! I’ve got minibook X N100 version and installed ubuntu 23.04. All works normally, bu the wifi card is not. Card version is wifi 6 AX101 (windows has working drivers).
Did anybody solve this issue?

Switched to kernel 6.5 from 6.2, wifi works!

1 Like

Could anyone rotated screen in grub?
Model is n100.
This did not help: fbcon=rotate:1

(Login screen rotated via monitor.xml file)

Grub does not support display orientation changes, unfortunately. For rotating the framebuffer (used by virtual consoles and the verbose boot process for example) you can use what you already mentioned (fbcon=rotate:1), and for the main OS you can actually use video=DSI-1:panel_orientation=right_side_up instead of manually adjusting it in your system monitor settings, which is a bit nicer/cleaner. Unfortunately, Grub just never ended up having support for display rotation added, so there’s nothing we can do there — short of setting its timeout to 0 so you don’t see it at all, but if you’re multi-booting that’s not really going to be helpful of course :).

Some things I’ve stumbled across for the good of the community:-

  • kernel params max_cstate and i915 enable_psr=0 are both red herrings.
  • the root cause of the ‘display tearing / wake-after-sleep / corruption’ is the panel being put into an unsuppored timing mode by various modesettings invoked by the kernel drm…
  • not that I’ve solved the underlying issue ( I’m working on a custom edid file but I don’t have a lot of time )… you can alleviate the symptoms by invoking:
  • xrandr --output DSI-1 --off; sleep 2; xrandr --output DSI-1 --mode 1200x1920 --rotate right
  • the wifi can be fixed by adding “options iwlwifi disable_11ax=true” to /etc/modprobe.d/iwlwifi.conf and regenerating your initramfs.

anyways… good luck.