Linux not running in Aerobook pro 15.6

The original add, promised it would run MacOS and Linux, but I have tried Ubuntu, Fedora and Manjaro, neither one is able to start a live session. Is there a guide to run Linux in this machine?

Same here, thanks Chwui Team for guidance :orange_heart:

Did you manage to install a linux distro on the aerobook pro? I came across this file (EC- Linux installation Aerobook Plus 8G) in another thread which suggests that Chuwi do want to help linux users with an installation. Have followed the instructions in it but it seems to be an old instruction guide and it now fails with the aerobook pro with bios version CW-BI-SU156SWR100-SA66B-001-H and EC version CH-EC-V7.0.14. Any suggestions?

Configure the BIOS as follows.

Advanced
CSM Configuration
CSM Support [Enabled]
Boot option filter [Legacy only]
Storage [Legacy]
Video [Legacy]
Other PCI devices [Legacy]
Security
Secure Boot [Disabled]

Boot
Fast Boot [Disabled]
Also, boot media is made by rufus-3.11.exe.
Partition Configuration; MBR
Target system; BIOS or UEFI
File system; FAT32
While Boot up,

When the Ubuntu boot menu appears, choose "Try Ubuntu without
installing it " and press F6 to ESC to edit the start-up options, so
add “acpi=off”. And press Enter key.
And when you do Ubuntu Install, grub install is the last without any
skipping. Safe until the end!

The following seems to be the key,
GNU GRUB version 2.04
"setparams ‘Ubuntu’
set gfxpayload=keep
linux /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed maybe-ubiquity
quiet splash —

initrd /casper/initrd"

Edit to

" linux /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed maybe-ubiquity
quiet splash acpi=off

I doubt they must have promised this as it cannot run macos, can only do hackintosh os lol.

Maybe chuwi team needs to have someone from linux community to help them with optimizing their device hardware for linux platforms.

I’ve tried to contact them but currently they’re not interested, once they’re interested then they can take support from linux community for their hardware.

Try, Manjaro XFCE 20.1 Linux x64

For people who want a reliable and fast laptop. This edition is supported by the Manjaro team and comes with XFCE, a reliable desktop with high configurability.

Download from here:
https://manjaro.org/download/#Official

1 Like

OMG do not do this. :grimacing:

I had successfully replaced windows with Linux MINT, and to stop the screen flickering I had cranked the screen resolution down to 1600 x 900 and the flashing reduced to acceptable nuisance.

I then thought I’d try tweaking the bios settings and followed this.

I was a bit unhappy because it changed the UEFI to legacy and I’d overcome that problem. In theory UEFI offers some protection.

Anyway restarting after these changes caused the screen to flicker so bad that I couldn’t even see what the BIOS setting were.

Then I realised that I could still get an HDMI display working. That allowed me to get into the BIOS and reset to defaults.

Now everything is back to normal, Linux MINT is wonderful.

Two things I noticed and I wonder if I should report these as issues.

  1. Just plugging the HDMI cable in stopped the flashing so I could have used the laptop screen then.
  2. Once the machine rebooted, the HDMI screen was the 1600 x 900 laptop screen in the top left corner with the whole of the 3840 by 2160 full screen .

There’s definitely something weird going on with the way that linux drives the display and I suspect (with my electronics hat on) that drives the display chip out of limits.