Linux on Chuwi Minibook 8

Hi, I tried to install Linux (Linux Mint, Ubuntu, Mageia) on the M2 SSD. Unfortunately, after a while the system was frozen. I found that this is causing with NCQ, so when I last installed Mageia 7, I turned it off in the kernel (libata.force = noncq).

System no longer freezes, but it still reports on boot other errors.

ata1.00: status { DRDY }
blk_update_request: I/O error, dev sda 14903128 op 0x0: (READ) flags 0x80700 phys_seg 12 prio class 0
ata1.00: exception Emask 0x50 SAct 0x0 SErr 0x280900 action 0x6 frozen
ata1.00: irq_stat 0x08000000, interface fatal error
ata1.00: SError: { UnrecovData HostInt 10B8B BadCRC }
ata1.00: failed command : READ DMA

Have somebody the same experience like me? Or is there a choice in the BIOS which should I choose? Thank you for your help.

haven’t experienced a similar thing. installed debian testing and works with one problem - when i shut-down, the computer reboots (in windows it shuts-down with no issues)

Do you have installed Debian to the emmc or to the m.2 ssd disk? Thank you for the answer.

installed to the m.2

hi, I tried to play with my chuwi minibook (i have version with Celeron N4100) and if I install linux on emmc, I have no problem with errors or freezing (I don’t have to turn off NCQ)

I have problem with errors or freezing only if I install linux on m.2 disk

Probably this is a problem with pci driver.

Please install it on emmc and share the output of this command
uname -a

I need to know the kernel version. If you’re on older kernel then maybe yes you will have driver issue.

Another way to find out is.
Install on emmc and start the system if everything is working fine. Then power off and install m2 drive but boot from emmc.

Once inside the emmc os, try to make use it m2 drive space by reading and writing files to the drive and if it crashes that means its the driver issue. If it works then its something else.

Please try this till then I will share how to check if m2 driver is present in kernel module.

Please share output of the following. Make sure the M2 drive is connected to the Minibook.

  • ls /dev/ | grep nvm
  • lsmod | grep nvm
  • modinfo nvme

@spikerguy thank you for your answer

i have tried on m.2 disk ubuntu mate 18.04, 19.10, cinnamon 19.3, mageia 7.1, manjaro 19 - the problem was the same

i have now on emmc mageia 7.1 with this kernel, as you can see after command uname -a:

Linux chuwi-minibook 5.5.9-desktop-1.mga7 #1 SMP Thu Mar 12 08:02:44 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

when i installed linux on m.2 disk i had boot partition /boot/EFI everytime in emmc, i had dualboot with original W10, i can’t install boot partition on m.2 disk due UEFI

i copied files from flash drive to mounted partition on m.2 disk and errors are back as you can see in this file logy.txt (it starts in 20:19:58 )

output of your commands are there (unfortunately nothing):

[root@chuwi-minibook alda]# ls /dev/ | grep nvm
[root@chuwi-minibook alda]# lsmod | grep nvm
[root@chuwi-minibook alda]# modinfo nvme
modinfo: ERROR: Module nvme not found.

So just to understand your situation, you have windows10 on emmc which has its own efi, and you installed linux on a different parition alongside w10 on the same emmc. this means you get a grub screen on every boot right ? This grub is coming from the emmc, while this grub is directing you to boot linux from the emmc.

Not sure what you mean by this. I see that it is failing to load and I suspect it is something to do with the M2 SSD. I will have to check with the dev and get back to you.

Also this shows that there is no NVME mod. Idk why.

Give me sometime.

thank you for your time and your help

hi, I moved Windows 10 to SSD drive, but I found that Windows Event Viewer is full of warnings: Event ID 153 Disk Warning, so the problem with linux on SSD is not software problem but hardware problem

better choice would be if the problem was only with the SSD, worse choice would be if there was a problem with the SATA controller on board

is there somebody who know how to check it without buying a new ssd drive?

Which SSD do you have on it? The exact model i mean…

original, which gives Chuwi there:

Netac M.2 SATA 6Gb/s 2242
model: S535N128G

I have the same issue. Did you ever find an answer? I even tried with a new 512GB Transcend M.2 SATA SSD, but I still get these errors.

Errors seem to be present on Windows as well as on Linux.


What errors?

Maybe the drivers are not fully stable.

You might have to dig into that logs to find out more if youre still running linux on it.

These errors, which indicate the connection between the M.2 SATA SSD and the computer is unstable. This is likely a hardware issue or a firmware/EFI issue.

[  148.147043] ata1.00: exception Emask 0x40 SAct 0x0 SErr 0x880800 action 0x6
[  148.147046] ata1.00: irq_stat 0x40000001
[  148.147048] ata1: SError: { HostInt 10B8B LinkSeq }
[  148.147051] ata1.00: failed command: WRITE DMA EXT
[  148.147055] ata1.00: cmd 35/00:40:d0:6f:35/00:05:00:00:00/e0 tag 13 dma 688128 out
                        res 51/84:40:d0:6f:35/00:05:00:00:00/e0 Emask 0x50 (ATA bus error)
[  148.147056] ata1.00: status: { DRDY ERR }
[  148.147057] ata1.00: error: { ICRC ABRT }
[  148.147061] ata1: hard resetting link
[  148.619063] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[  148.624418] ata1.00: configured for UDMA/33
[  148.624441] ata1: EH complete

smartctl --identify:

I guess it is a firmware issue as the ssd you must be using might be having higher speed then the board can handle, that can be one of the case.

Maybe chuwi team can suggest something.

Good luck.

SSD is same speed as the one that came with the computer. The SSD that came with the computer has the same issues.

Both the computer and the SSD(s) are specified to support SATA III 6.0Gbps.

Then I am running out of options here :frowning:

Chuwi should work with a linux distro to get a pre installed image for their devices.

They did take interest in a poll to see how many are interested in linux but I think they only asked in the forum and not on public platform.

Let’s see if they do that in future.