Linux sound for the Hi10 X

As has been pointed out, until the very recent Linux kernel 6.2 (up from 5.9), sound has not worked on the version of the Hi10 X with the ESSX8336 sound hardware. With kernel 6.2, it works, but several things have to be massaged in alsamixer in order to make it work. I have the latest daily build of Ubuntu Mate (the final version doesn’t come out until next week) installed on my Hi10 X, and I’ve written a script to automate setting alsamixer to the right values. Calling this script from ‘Startup Applications’ will invoke it at boot and make sound work automatically. This script, or some variation of it, may also work on other versions of Ubuntu, or even other versions of Linux. Its effect is to feed sound out through the speakers, or the headphones if they’re plugged in. Here it is:


amixer set ‘Headphone’ unmute
amixer set ‘Headphone’ 3
amixer set ‘Headphone Mixer’ 11
amixer set ‘Speaker’ unmute
amixer set ‘DAC’ 192
amixer set ‘Left Headphone Mixer Left DAC’ unmute
amixer set ‘Right Headphone Mixer Right DAC’ unmute
pactl set-default-sink

(don’t forget to make the script executable)
(also note that the way things are named in alsamixer for the ESSX8336 doesn’t make a lot of sense!)

To switch over to sound output through HDMI, the following script works:


amixer set ‘IEC958’ unmute
pactl set-default-sink

I have these two scripts linked to launchers in the upper panel so I can quickly switch back and forth.

honestly, i just hope the es8336 issue is not happening.

i wish everyone could buy an economic windows tablet.

when i was young, there was no/little chinese brand and only
japs brand.
they are fxxking expensive.

only recently esp after 2010,
when windows start to fail… there are chinese LOCAL brands begin producing windows tablets

EDIT - One thing I forgot to mention: in order for the HDMI sound output to work, you need to select ‘Pro Audio’ in Sound Preferences > Settings for the selected device. This stays selected after shutdown/reboot, so you only have to do this once. This could probably be done in the script, but I’ve been too lazy so far to figure out how.

Also, if you don’t get speaker sound the first time you try the first script, try going into alsamixer and mute, then unmute the speaker (3rd item from left). This should only ever have to be done once, if its even needed.

Nice, I got some problems getting everything to work with chrome os, and Linux mint, but everything worked flawlessly with fedora