Lost Internet Connection

I bought a Chuwi Herobook for my partner. All was fine until this week when we cannot connect to the Internet. When we go to Network Status it does not show any networks. It just comes up with Activate Windows (Go to Settings to activate Windows). I cannot however activate Windows because it comes up saying ‘you are not connected to the internet’ so we are going round in circles.

When I press Trouble Shooter it comes up say that the Realtek 8821CE 8821CE Wireless Lan 802.11ac PCI-E NIC adaptor is not fixed experiencing driver or hardware related problems. I tried using Cortana but that did not work. The other thing I think I could try is to uninstall the Reltek LAN then switch off and switch off again but I am concerned I might land up doing more damage.

The laptops is only three months old so I would not expect this to happen. I would be very grateful for your advice.

Many thanks,


Lost Internet Connection Fix
Try a factory reset, by the BIOS.

You can go to the device manager and check if the Wifi is listed in the network adapters tab. If a blue triangle appears and shows, you will need to reinstall the driver as a 100% unsupported driver may have been installed during a Windows update
Click on it with the right mouse button and click on properties, driver, update driver or test if the option “revert to previous driver” is active

Thank you very much for the advice and we will give that a try when my partner comes home later and lets me have the password!

Happy to say the advice worked and my partner is back up and running! Many thanks,