MiniBook dead after EC update


I’ve tried to update the EC firmware to turn the fan off (found in other topic). Just to realise afterwards that this file was for 8100 systems. I have a N4100 system. The result is that the laptop won’t start at all. The only thing it does now is when I keep the power button pressed for 15+ seconds, the blue light at the keyboard starts flashing until I release the power button.

I’ve already found the 4100 European EC.bin on indiegogo and flashed the EC (GIGADEVICE 25Q80CSIG 3v3) with the use of a CH341a programmer -> no luck. Laptop still dead.
I’ve also flashed the BIOS (GIGADEVICE 25LB64CVIG 1.8V) with the file for 4100 found here
-> Laptop still dead.

How is it possible that the laptop is still not working after flashing both EC.bin and BIOS.bin?
What more can I do? Any suggestions are much appriciated.

Generally,we don’t recommend users to flash the BIOS file on their own, since this may cause permanent hardware damage

Probably you have hardware damage.

You would expect that, when official files are put online on the manufacturer website/forum, you can use them without instant problems. They even provide a link to a tutorial with it. The real problem is that files are offered without specifically mentioning for which system they are made, which indicates to me that they are generic… which they are clearly not.

I’ve already contacted the service department. They are out of business until February 20 because of the Corona virus.
So I hoped to find a solution here.

as far i know, using usb ch431 for my 4745G,
i am flash using bios from official installer(extracted bios bin file), and laptop still dead.
you must flash “dumped bios” file from healty device with same spec.

I’m hoping someone has a N4100 system and dumps of the EC, and maybe BIOS. But I guess that’s wishful thinking. I’ll have to wait for the guys of support to return.

Too bad the community around Chuwi products is so small. I can’t get my problem resolved and Chuwi support seems non-existant at the moment. So I’m stuck with a brick.

I shouldn’t have ignored all the negative feedback on the forum, and indiegogo website. My ignorance kicked me in the bu** :’)

I don’t think community is small, maybe nobody else have the same problem with you. Have you tried booting with usb stick containing either EC or BIOS?

Not possible. The laptop doesn’t turn on anymore. Looking at videos on YouTube, I wonder if my unit was bad from the beginning… When I wanted to power on the unit, I had to keep the power button pressed for 5 seconds. If I look at the videos, those units turn on after only a short press.

I get the same problem!! turn to be brick after update this patched ec. wanna cry! have u make it work??

No, sorry. I didn’t get it to work again. Tried everything possible with an external flasher. Emailed support, got a reaction from them with links to EC and BIOS files, but that’s not going to work. Emailed again, but radio silence for a week now.

I also wrote a reply in the BIOS,EC,Software topic about their false/missing information about only one EC file which is offered, but no reaction either. Support is not existing for Chuwi products, be aware.

It’s an expensive coffee cup holder at the moment, and I don’t think it will ever be more than that.

BTW, they reply really quick if you have questions about buying a product. Seems their only interest ATM.

so I will telephone chiwu tomorrow. it seems impossible for me to repair. I plan to return it to seller or chiwu for repairing.

I wonder how do you flash the EC chip with the CH341a programmer?need to open the shell and get out the chip, which is supposed to welded in the motherboard?

You need to open the bottom cover, so you void the warranty sticker. Then you use a SOIC8/SOP8 adapter clip to program the EC chip. You don’t have to remove it from the board.

thx,got it. i have contacted chuwi, and the seller help me return minibook to chuwi for repairing. It is really difficult for me to fix it myself. next, what are u going to do? fix it yourself?

I still hope to fix it myself. As soon as communication with support is possible again, I hope to get the needed firmware dumps to try to recover the Minibook. Sending it back to China, without knowing the repair costs, is not an option I prefer.

I can probably get a BIOS dump for you. I’ll have a go. This is if programmer behaves. I also need an EC dump!

Dear sir! My laptop has exactly the same problem. The correspondence with the support service did not lead to anything. Please tell me if you managed to get the firmware file? If so, please share with me by email, or post it here. Thank you in advance!

What did you end up doing?
I experienced the same problem while updating the BIOS and I couldn’t find a way to fix it.
I know have a broken computer since more than 3 years …

Was anybody of you able to resolve the issue and bring back the laptop to life?
Thank you