Minibook 8100Y no hibernation

I’m unable to set-up the system to use hibernation. When I run ‘powercfg -h on’ I get the following error:

The system firmware does not support hibernation

Why is this not possible? I cannot enable anything in the BIOS so it can work… Is there any driver available for windows which will support hibernation function?

So I guess nobody is using this very basic functionality, which every laptop of mine had since 2006?

I don’t dare to update the BIOS… My Minibook N4100 still feels the pain of that.

have u got your minibook worked? if i dont remember wrong, you minibook suffered serious problems like mine.

I didn’t manage to get the N4100 working again. I bought an 8100Y instead to keep on working. Still have to decide what to do with the other device.

1 Like

Hey man I was wondering what steps you went to to Flash your 4100. I fxcked up mine too. I’ve been trying to flash it. First of all did you bad out the ec.bin? The ec.bin size is 131072b and my bad flash is 1048576b. But I can’t be sure about the bad flash size. I had a look with xxb to see if the bad flash is just padded to size by the programme that flashes it. But I don’t really know what I’m looking at.

Let me know what you think. I am sure we can fix this. Even if we order the EC chips from ebay and flash them separately. I am getting unreliable flashes with my programmer so it might be faulty as well.

If CHUWI would just send a EC DUMP for a 4100 we wouldnt have to be guessing :face_with_raised_eyebrow:

I have been comparing BIN file and DUMP file from EC, even when I compare my faulty flashed 8100Y EC dump with 8100Y bin I see differences, not something like padding I guess. There is a kind of pattern in it. Maybe flashing from the USB stick operates on a different way and does alter the flashed content while writing (security or something?). Our best option would be a full BIOS dump and full EC dump from a working system. That way they are perfectly matched if any checksums would be active.

Did you check that you are at the correct voltage when reading/writing the EC memory chip? The BIOS chip and EC chip both operate on a different voltage, which can result in unreliable readings if you use the wrong voltage with your programmer.

When I have some spare time I will pick up this project again.

1 Like

My ch341a has been modified to give the correct voltage 3.3v. It’s a 3.3v chip from what I’ve read. I know I can’t get reliable flashes. from it though. Good to know about you having a look at the dumps. My bios hasn’t been touched so it might still be worth it for you if you want me to have a look. What’s the voltage of the bios chip? And where is it?

Not looking like padding is a big head’s up for me. BTW I can only do 3 posts in a topic. So, I’ll just keep editing this one if you reply :grinning: