Need Hi10X (CWI529) HID touchscreen / HID pen drivers for Windows10 22H2

Hi guys.
I have little hope about this issue, but try to ask someone’s help.

My Hi10X’s touchscreen stopped working correctly after updating to Win10 22H2.
The upper area of the screen doesn’t respond to touch or pen input. In fact, when calibrating touch/pen input, Windows recognizes screen area wrongly (1080x1080 square area at the upper left of the screen) and even the area doesn’t match with actual area responding to touch/pen.
Device drivers seem to be working with no error. The touchscreen controller seems to be GXTP 7386 which communicates through I2C bus.

I’ve tried reinstalling existing device drivers and no avail.
How can I solve this issue?
Is there someone who is using Hi10X with Windows10 22H2 without any issue?

Thanks in advance!

can you please give me your serial number?

S/N is Q128GH62040383.

PS. Ah, I should mention that the touchscreen worked correctly when Win10 release was 1904. After upgrading to 22H2 (or 2004), the touchscreen stopped working correctly. So something like a new device driver or new configuration (including BIOS update) seems to be needed.

PS2. I tested the method written in the article below, but no avail. (To make sure, the file in this article were scanned by WindowsDefender and no threats)

After trying some methods written in the forum, I have confidence that the configuration of touchscreen controller is wrong.

UBOOK(4100 model), Hi10XR, and Hi10X are equipped with Goodix’s touchscreen controller GXTP7385P, GXTP7385, and GXTP7386 accordingly and their configuration formats seem to be compatible. I tested 3 configurations (didn’t use drivers nor firmware) and confirmed that axis directionand responding can be changed without device driver error.

So, if I could get the datasheet of them, probably I can create the proper configuration for GXTP7386. However Goodix doesn’t provide the datasheet. Who could tell me the place where I can get it?

Could you provide me a sample model of a datasheet, so would be easier to explain to tech?

Anyone who designs digital circuits or codes device drivers reads datasheets. It describes anything about all of functions of a specific LSI. Datasheet is supposed to be used by developers, often requires non-disclosure agreement to read.

E.g. you can get datasheet of LS74 easily but cannot get datasheet of Intel N4100.

Could you negotiate with Goodix about the availability of datasheets of GXTP series?

I commented about this issue, the thing is we dont have those datasheet. They will try but i think would take a lot of time. On the meantime.If you could please try this one: is also related to the touchP. Install these drivers:

Thank you for the replay.

I tried to update the device driver you brought and got the messages below.

C:\Users\XXXXX\Downloads\Phoenix-hid-update-G109D-20200715>echo off
******update firmware, file name:GT7382H_A1.00.02(A92E).bin
open TLC success
before update, read VERSION success
VID befor update:00 a1 00 01
fw_image Initialize success
error—Reg 0x5095 != 0xDD
error—Update fw failed, retry=0
Found a valid sub subsystem start loading, type:0x02
Sub FW addr=0x0, len=126976
update GM11 success
Found a valid sub subsystem start loading, type:0x0b
Sub FW addr=0x200, len=32768
update G1 success
Update fw success
after update, read VERSION success
VID after update:00 a1 00 02
Press any key to continue . . .

Could I think the update was done successfully?
(Anyway, touchscreen doesn’t work correctly and the update of configuration was done successfully.)

I tried 3 times to upgrade firmware and it seemed to be successful.
But, the configuration you brought is worse than’s configuration. Your configuration is working within pretty narrower space then’s which works except some amount of the upper area.

So I have confidence that the configuration is the only matter we should think of.

With vivio’s configuration:

With the configuration you brought: