Please help me my device wont work

guys, please help me
first, my device crash when I am using it

so I format the device and now the device won’t work just the keyboard
please help

Probably some system files are corrupted. Try to reinstall windows.

that what I was going to do but I can’t start the device only the keyboard black-light works the screen won’t work

Try to hold power button for 40 seconds and then try to turn it on.

did not work it blink blue then nothing happen even the keyboard won work now

when you plug smartphone to usb port did it charging from tablet? You can full discharge the battery, may be it will help. Or you can just unplug battery for some time if you can disassemble tablet.

i need to hold the power button to charge my phone

That is very strange. I think detaching battery can change something, but it will be better to contact

ok I will connect them thanks max

The “IRQL Not less or equal” should be related to an HW Driver conflict.

and can you tell me please how to fix it

If i well understood now your main problem is to star the UBook. Before to format as you done better to try with Win10 Solve Problem in Settings, than with a FreshStart…
Now you need at least to enter Bios. But if PC wan’t turn on i think is an HW problem…

ok thanks nickolas i will wait and see what chuwi says

Hi, I had this screen also a few times , I did nothing just let the screen run , after Windows message came that they would uninstall some updates who gave problem seems (Windows did many updates…! before.
After I installed new arrived UBook…) They also would review the updates…!
After all worked normal again , until a sudden again blue screen …… just let Windows do the job again and all became working order again …something must be giving Chuwi a “headache” as first time I got straight a BIOS screen message that Chuwi could not read ROM memory ….

(also as I was in Bios anyway I checked C access ….and indeed it was standing disabled , as some poster mentioned, so enabled it and all worked normal)

Until after those 2 times blue screen all works, must be some updates in my case ,better let Windows 10 repair it (telemetry must be on )

The latest Windows Update KB4524244 is causing issues on some computers. I have it installed but I am not seeing any problems. I am thinking about uninstalling it as Microsoft has pulled it from release.

I updated it and no problem on my Asus , but on my Chuwi Ubook pro I had blue screen , I let Windows resolve it and indeed they removed some update , I think the latest poster’s problem as no more starting, is related to it reading in Zdnet article