Problem with Clock

I have 3 clocks, the Windows Taskbar clock and 2 Gadgets Every time I close down my PC all 3 stop running, so on re-boot I have to start them again, in Settings. Each time I turn automatic off then back on the clocks update, in unison. This happens with all the options, Sleep, Hibernate, Restart, Shutdown. I have never experienced this before, what do I need to do to keep the clocks running? I have tried both automatic and manual Settings.

One suggestion is to replace the CMOS battery, but I have only had the machine one month. CMOS batteries are expected to run at least 2 to 3 years.

There is no cmos battery in this tablet. These types of problems are usually solved by reconnecting the battery or flashing the BIOS.

After several checks (and without the Gadget clocks). including what the Clock shows in BIOS, it now seems clear that while the TabletPC is shutdown (including sleep, etc) the System Clock does not run.

Further advice on how to deal with this would be welcome

If you don’t want to teardown the tabler or flash bios+EC you can contact with aftersale@chuwi.com
Probably they will provide information on how to solve this problem or determine what the problem is.

Thanks – I will report back if there are developments.

clayto

I need your help, I have chuwi Hi 10 X tablet, Windows 10 system, and pen. HIPen H6, the tablet does not activate the pen, what can it be?
Thank you

Make sure you have Q128GH6 in serial number. If yes - try to update config & firmware.

I may have found the cause of my problem but cannot correct it. In Services I cannot get Automatic start for Windows Time (Clock) to work. It is stuck on Manual and clicking Automatic does not change it.