RAM and SSD Gemibook X upgrade

Greetings. Sorry my bad english.
I just got a Gemibook X laptop and I want to upgrade its RAM and SSD. SSD un laptop Is a 128gb Drive and I think is a SATAIII. The thing is I want to upgrade this Gemibook X Laptop to One 512GB SSD PCIe 3X4 NVMe and 2667MHz RAM, but I don’t know if they are supported in this Gemibook X Laptop.
Can somebody help me to solve these questions? Thanks un Advance.

Hello, one of the 4RAM can be replaced, and one of the 128SSD can be replaced, thank you

La laptop es una Laptop Gemibook X con procesador Celeron N5100. No me queda claro su respuesta. En concreto Gemibook X soporta DDR4 a velocidad de 2667 MHz y 2933MHz? Gemibook X soporta unidades de estado solido NVMe PCIe? Gracias.

Hello, I’m also interested in upgrading Gemibook X with this Kingston M.2. SATA SA400M8/480G. The laptop has a soldered 4Gb Ram module, and one free slot, which I would also like to use, but I’ve tried a kingston DDR4 2400mHz 16Gb and din’t worked, so, should I use a RAM module with higher speed? It’s suposed to support up to 32Gb RAM as stated on the official website.

Hola atmelc, ¿como le fue con su upgrade? me interesa tambien hacer un upgrade, pero estoy pensando sustituir el SSD de fabrica, con uno de mayor capcidad. Verifique el el de fabrica es un M.2 SATA, con entrada tipo B+M, mientras que la ranura libre admite una entrada tipo M. Entiendo que hay conflicto si se instala un NVMe junto con el SATA. Me interesa incrementar la capacidad de almacenamiento, asi como la RAM, pero no me acepto una kingston DDR4 de 16G, tal vez por que la velocidad fue de solo 2400mhz.

Grettings. 32GB ram is false, i’ts another lie of CHUWI just like when they describeded me Gemibook X on a page where I got it that supported M.2 SSD NVMe. Because each module should support 16GB and there is a 4GB module soldered already, and as you mentioned just there is a free slot for a 16GB maximum capacity. So 4GB+16GB=20GB RAM Maximum in any case. According the seller or provider where I got GEMIBOOK X, told me 2400Mhz modules ram are correct to use, and they should be SO DIMM 260 PIN. Someone in my country México told me to have tried a 2667 module ram of 8GB without any issue. Obviously the speed that will work in it will be 2400Mhz due to the soldered ram is a 2400Mhz module. The module ram that you installed should have worked. But I wouldn’t be surprised if it were just another lie from Chuwi to claim posible using a 16GB module ram when the real thing is that Gemibook X just accept a 8GB module. About Upgrading the storage, don’t even try SSD M.2 type NVMe PCIe, since if you set one of it in free slot the device will not turn on, even you pull out the original SSD module and you set in the free slot. I did try, the laptop try to turn on but 3 seconds after, the light on the power button goes dim and device turn off. And If you replaced the original SSD SATA module by a NVMe in the slot before occupied for it the UEFI will not recognize and will go directly to BIOS/UEFI settings. Indeed the support of this brand is not the better. Sorry my bad English.

I’ll try using an 8Gb RAM 2666 Mhz module instead, also will try to replace M.2. SSD SATA with a larger storage. Will try to clone the factory included SSD and replace it with the new one once cloned. I’ve seen Crucial and Kingston seem to be compatible, at least in this forum with Gemibook pro. So I’ll try to stick to these brands and will let you know.

As I have told you before I’m bad at speaking English . Please translate with browser translator.
Gracias por su respuesta. Si ya he visto el Post del compañero Uni-panda pero él ocupó un SSD NVMe modelo CT500P2SSD8 y NO un SSD M.2 SATAIII. SI usted se arriesga a probar con un SSD Crucial NVMe CT500P2SSD8 como el que instaló el compañero Uni-panda y tiene éxito, seria bueno que usted hiciera un post con los pasos para ayudar a las personas que no tuvimos éxito instalando un SSD tipo NVMe en la laptop GEMIBOOK X.

Por el momento el cambio de capacidad en el almacenamiento de mi laptop es el menor de mis problemas. Yo al estar haciendo pruebas por error conecté SSD Original en la “ranura libre” de forma invertida y no se si provoqué un choque electrico en el SSD Original o en la motherboard misma y ahora el SETUP BIOS/UEFI no me reconoce el SSD SATAIII original.
Abusando de su amabilidad le pediria a usted de favor que de ser posible despues de hacer la clonacion del SSD original si podria hacer un respaldo de dicha clonacion y subirlo a la red para tenerlo de respaldo para todos los usuarios de GEMIBOOK X.

Good evening.
So, I did tried a new RAM module, used a crucial 8GB 2666MHZ, and it worked fine. So I guess the issue was that Gemibook supports only 16 GB RAM, and has 4 already installed, hence, adding a 16 GB RAM will result in 20 GB. So, maybe a 8 GB 2400 MHZ will do the job too.

Also, got an M.2 SATA SSD 2880, a kingston, 480 GB. Used macrium to clone, up to this point, eberything was fine a got a pretty neat image. The equipment started good at the beggining. But the, I noticed WLAN was not being recognized. It wouldn’t detect any. Bluetooth was working fine though, so not a hardware issue. Tried using BIOS to fix, but got no result. Also, updated drivers, to no avail. It wouldn’t work, also, could not access to device administrator, and could not access it.

I got a message about not being recognized. So, since I had replaced the original 128 SSD with the 480 one, decided to install the first one back… and problem solved.

So, I’ll try to use the second SATA M.2 as a backup disk, or see if there is a way to solve the WLAN issue.

I’ll figure out how to make a good, errorless cloning, and see how can I upload it.

Yo no tenia de donde clonar ya que mi disco original estaba averiado. Yo hice una instalación desde cero con el link que proporcionan aqui en el Forum para instalacion de sistema operativo. Instalé Windows 10 y posteriormente actulizó el mismo sistema operativo a Windows 11 sin ningún problema.