Gemibook with NVME drives?

I am having an issue trying to get this new Gemibook to detect an NVME m.2 drive. I have tried two different ones without success.
I have tried so many different bios variations but my normal one of switching to Legacy boot mode is not available in the bios
If anyone knows how to enable Legacy mode on these I can try a few other options.

3 Likes

My Gemibook doesn’t work with NVME disk drives. They are not detected in bios or system. Anyone could help with this? How to enable NVME support in bios?

2 Likes

exactly the same thing happens to me, gemibook does not detect NVME m.2… help please!!

Alguién puede ayudar?

Gemibook doesn’t support NVME :frowning: This is official respond to my question from Chuwi support: “We are sorry that our machines are not compatible with nvme SSD. Our machines are generally SSD compatible with SATA protocol.”

2 Likes

Same here.
Wasted 2 hrs of my life trying to install a Samsung 970 EVO Plus 1 TB PCIe NVMe M.2 (2280) Internal Solid State Drive (SSD), not detected in BIOS/ System no matter what I tried.

Shame CHUWI.

Chuwi still says now “What’s more, GemiBook supports NVMe protocol 2280 SSD” https://www.chuwi.com/product/items/Chuwi-GemiBook.html

Wont trust Chuwi anymore.

1 Like

It’s either deceiving or extremely ignorant, any of which is terrible. Definitely dissapointed, I counted on having my cutting-edge NVMe installed on my Gemibook…

I also have the same problem . So,I asked Chuwi support desk to solve it. The answer is here.

Hello, he only supports SATA

Regards Jim
aftersale-service@chuwi.com

My Gemibook runs with M.2 SATA SSD without any trouble but cannot detect NVMe card.

I think it is just a bios issue and should hopefully be sorted fairly soon.
I have requested a raw bios file so I can inject my own nvme drivers into it and rebuild the bios and see if I can get it to recognize, I have had this issue on a few motherboards that I was able to patch the bios to support nvme.

So hopefully then get me the file soon, or they fix it themselves and release the bios fix.

1 Like

is problem solved?

solved?