Sound not working in Windows 11

I’ve installed Windows 11 on my CHUWI UBook CWI509 N4100 and it works everything but the sound card.
I’ve tried installing drivers from here:

to no avail.
I’ve also installed Debian Bullseye in dual boot and everything, including sound, works fine.
Audio used to work fine with Windows 10.
Maybe someone has some suggestions?
Thank you in advance…

I have the ubook m3 6y30 and the sound runs ok in Windows 11.

I do not know if it is the same sound card.

But it must be drivers issue.

Did you install from 0, or over Windows 10 ?. I did over Windows 10 and everything was perfect…No need any driver instalation.

Hi Ruben,
thanks for answering, I made a clean install to be sure to have a clean system.
Drivers from Chuwi website and drivers from Intel website cannot be installed…

In my ubook, the sound card is a realtek. I have to assume that it is the same …

Windows update, in the optional updates section, does not detect sound drivers?

I’ve selected to download the optional updates too, but Windows does not find any driver for my soundcard…

I installed Windows 11 as a update from Windows 10 in a UBook 11,6 with N4120 processor. This are the Audio drivers I have:

drivers realtek 1

drivers realtek 2

drivers realtek 3

I hope it can help you.

My microphone not works, please help me, my ubook have Celeron

Install the intel driver support assistant and it will detect and install the latest drivers. The realtek audio drivers are bundled with the graphics driver.

I installed Intel support assist, it has the latest driver version, but the microphone is bad, hissing and the sensitivity low.

Does anyone know what device this is and how do I install the driver?

What device did you connect before via bluetooth?

The only bluetooth device I used on the ubook was a simple Chinese TWS headset and it worked correctly. I’m trying to reinstall Windows 10 from the factory (Chuwi) let’s see if it solves the problem with the phone and drivers.

I reinstalled Windows using a backup image made in Windows 10 ( factory), but the sound problem got worse, now neither the sound nor the microphone work.

Can someone help me? I need the sound card driver, why doesn’t Chuwi setup the drivers like other manufacturers?

You may check with a live Linux distribution (Debian Live, Knoppix, etc.):
if the sound works then it’s a problem with Windows11 drivers;
if it doesn’t work then it’s an hardware problem…


I tried everything, installed 3 different windows images and in all the sound was not installed, with realtek driver the driver was installed but the sound didn’t work, I read in a post here on the forum a person with a similar problem, he said that after hitting the back of the ubook the sound came back, so I opened the ubook and reconnected the speakers and the sound started working again, but I’m not sure where the problem is with the hardware. Does anyone have any idea what this problem might be?

Realtek link of download


after a lot of troubles looking for the right driver, I found that the problem could be related to this issue confirmed by Micro$oft:

However, fiddling in the BIOS settings I found a workaround to my problem.
Entering the BIOS settings (Fn+F7 at boot), under Chipset, South Cluster Configuration, HD-Audio Configuration, there is “Audio DSP Compliance Mode” which can be set as “Non-UAA (IntelSST)”, which is the default, or “UAA (HDA Inbox/IntelSST)”.
If it’s set to “UAA (HDA Inbox/IntelSST)” the device changes its name and its hardware IDs.
It also changes the driver to use, and (bingo!!!) this driver works!!!

I didn’t find the Chipset on Bios settings

You can update drivers or download latest drivers on Windows 11.