Windows 11 100% Supported

My Ubook X arrived yesterday I can say that despite CHUWI’s verdict, it fully supports Windows 11.

What worked for me without any driver issues was to

  1. Install all Windows 10 updates and upgrades until there are no more available (20H1 takes extremely long)
  2. Remove all update files (Clean Disk utility)
  3. Install Windows 11 upgrade assistant
  4. Install graphics driver from Intel: Intel® Celeron® Processor N4100 (4M Cache, up to 2.40 GHz)

This one is more recent than the version installed using Windows Update or Windows 11

Flickering lines were appearing occasionally from unboxing until only when the Microsoft Store is opened under Windows 11. The graphics driver from Intel fixed that after a few hours of use.

Everything on my machine is working and it’s more faster and responsive than under Windows 10. Battery life is better too.


could you check if microphone is working?

Everything is working! If you cannot get your mic to work use the drivers found in the forum. The mic uses realtek drivers.

How about the touch pen? Hope it works too.

Everything is working.

How’s your experience with Windows 11?. Is it more touch and stylus friendly compared to windows 10?

I am still using windows 11 on my Ubook X and I also have a USB with the stock Windows 10 ROM… read my first post.

Just upgraded mine to windows 11 too following your instruction. Works great!

1 Like

Yes. Mine arrived from Amazon on Thursday and the touch pad was a bit “iffy”, but with installing all the Win 10 updates, then running Windows 11 upgrade assistant, it was running win11 perfectly by Saturday, and it’s carried on updating win11 today so all is wonderful in the world ;-)} (I know it’s not, but at least this is working properly!)

1 Like

So far the only thing that I’m missing is the remaining battery estimated time

Also, the new WSLg fo Windows 11 haven’t worked for me at all. I’ve used it at my Acer Aspire Nitro 5, but it refused to work at my Chuwi UBook X

Win11 working fine.
Concerning the mic, I’m using the driver installed by windows when upgrading: Intel’s. To make the mic work I had to turn off the “audio improvement” tab (don’t know how it is named in the EN version) under the mic settings. Working fine.