The tablet stopped starting

He worked for two years. A week ago, it stopped starting. When the charge is connected, the red LED blinks. The same diode lights up briefly when you press the power button without charging.
I tried to charge.
What else can you try?

Maybe it’s bios fault. I did not find a combination to reset the BIOS, but I know one of the ways that helped to reset it.
You can leave the tablet connected to the keyboard and after about 4-5 days it will completely discharge. After that, hold down the power button for 5 seconds and the BIOS should reset. Then connect the charger, maybe after that the tablet will turn on.

Thank you, I will try this method

unfortunately did not help.
Are there any ways to flash BIOS?

Yes, but the problem may not be in the BIOS. It is better to use the help of a service center.

1 Like

Thank you. I’ll figure it out and will write according to the results

I’ve had the same issue for 2 weeks now. Was just fine and went to use it one day and it just did nothing. I’ve tried everything. Button combinations, battery discharging, and I’ve even taken it apart to unplug the battery completely. Still nothing. It seems to be an error with sleep mode according to past reports I’ve found and similar issues on other budget tablets. Will report back if I find a fix.

1 Like