This thread is removed

When I received my Hipad Pro, I have performed an update (menu “Wireless Update”). Informations linked to this update explains that the partition will be changed. This lead to an erase of the whole non-volatile memory. (I suppose that this update is to have the L1 certification)
What’s about this firmware? Does the L1 certification is already inside? What’s about the partition? Is it a new partition system, and/or only binary software are up to date inside?

1 Like

Your firmware version is still not updated to 2021.08.05 of the stock firmware from Anathema post.

So your flashing Stock firmware was not sucessfully done. I am looking for a way to enter QDLoader mode without adb command.

1 Like

The stock firmware from Anathema post is probably the most updated firmware with unlocked feature. Because gibus’s Hipad Pro that has been claimed is now unlocked. You can check from his post here.

Usually Android drivers that allow connection between PC and Android devices are provided by Google Andoird official website. But there are specific drivers for such types of Android devices as Qualcomm (QSD), Mediatek (MTK) and Unisoc (SPD) that require their own drivers for allowing specific access and functions. For example, entering Download mode in Qualcomm, Mediatek or Unisoc devices will require their own drivers and Flash tools to flash firmwares in Download mode. The device manufacturers like Chuwi don’t create drivers for specific devices since there is no need to do that. To unlock bootloader for specific devices will require the official unlock tools and specific methods. For example, Xiaomi Android devices require Mi Unlock tool with specific method to unlock bootloader. Or Samsung devices require Odin for flashing firmwares and unlocking bootloader.

In some specific Android manufacturer like Huawei, they don’t allow unlock bootloader since 2018 and they don’t provide official unlock tool or method anymore. So there is no possible way to unlock Huawei devices since then. I had Huawei P30 Pro in 2019. In case of Realme, there are some models of their each device that are not able to unlock. For example, Realme X50 5G allows only RMX2051 model that deeptest app (unlock tool) can unlock. There are about 5 other models of X50 5G that cannot be unlocked by deeptest app or by any means. I had Realme X50 5G RMX2025 and RMX2075 models in 2020.
Nowadays Samsung devices require no unlock tool to unlock bootloader. Just activate Deverloper mode and allow OEM unlocking. Reboot the devices and done. I have been using Android devices since Samsung Galaxy S1 with Android 2 Gingerbread over 10 years ago. Qualcomm devices are the best and standard with many great features. Mediatek and Unisoc devices are new with less features but still powerful. For example, Mediatek and Unisoc do not have L1 Widevine available or no Widevine. This cause Mediatek and Unisoc devices unable to play FHD or 4K or 8K movies by major streaming platforms like Netflix, Disney+, HBO Max and etc. Hope Chuwi will release more Qualcomm devices later on.

1 Like

My Hipad Pro with no OTA update still have L1 certificate intact as shown in the screenshots below:

I have not flashed the firmware from Anathema post yet. But I assumed that this firmware would probably unlock bootloader of Hipad Pro just like your claimed Hipad Pro got unlocked. This firmware is probably the latest updated available with 2021.08.05_02. I extracted the archived firmware and checked some .img files which are valid for Hipad Pro. So I assumed this 2021.08.05_02 firmware is valid for Hipad Pro.

BTW, can you checked your bootloader is still unlocked after OTA updated?

1 Like

I haven’t attempt to read a video with Netflix before to apply the L1 certification update. But I have test that after the update. Netflix is working fine but I can’t say if it is thanks to the patch.
I have an Android box connected to a TV; this box isn’t Netflix compliant but I can watch all series without any issue.

After OTA updated, the bootloader is now locked :frowning: . Good job Chuwi!

What is the tool you use to have those informations?

I used 3 different apps to diagnose Widevine certificate. You can type drm in Play Store.

Oh! now your bootloader is Locked! That’s sad for me.

yeah, so what it means is…the last OTA is locking the tablet.

super did you made the OTA like us? or even before/after the OTA your tablet was always unlocked?

I have not done OTA update once. Right after I received Hipad Pro, I flashed GSI ROM. As I mentioned before, I have had bad experiences with OTA updates so far. Used to permanently brick my Alldocube tablets with OTA updates. So I prefer update firmware by flash tool.

Now my Hipad Pro is on GSI system. There is no Chuwi OTA update available for me anymore. The only way for my device to get firmware updates is by QFIL (flash tool).

1 Like

Super when I connect my tablet to pc in EDL mode the pc recognizes well because it shows as pictures in tutorial when it says qualcommm hs- usb… To enter to EDL in chuwi you just need to press Vol up + vol down + power button at same time you have to wait until you see chuwi logo and it dissapear and you just release the buttons and connect to pc fast and that’s all. You can test it. But remember that you have to install qualcomm drivers for qloader and that’s all.

This is after second step and “download the firmware on device” and all is perfect

maybe spaces in the file name are in the way?

I dont think so. Because as I told You the whole process is complete and there are not errors in log


Just out of curiosity, could you manage to do all the steps and have your tablet working properly plus unlocked the tablet?

Thank you

Hi my friend after flash tablet is working but it just get stuck in a black screen after chuwi logo with android logo down. So it is bricked. And if I just go to recovery the bootloader is locked yet. I think that the problem could be the special partition that @super mention or there is something missing in tutorial because if you read the manual there is no explanation of how to enter in EDL mode so I was just lucky to find a video where someone press all buttons until the tablet did like a blink and stay in black screen and in usb recognized as qualcomm hs-usb 9008 qdloader. I can confirm that the firmware is the official because today sent the same link, but I have written them that review the firmware or the tutorial because there is something missing or bad.

1 Like

ohh @JOSHZ thank you for the clarification…and I know sooner or later, we will figure something somewhere on the web to reborn your tablet!

Does anyone has tried to contact the Chinese person that developed the user-guide on the first instance and confirm with her your situation and if she can help you?

Because I believe she has some tech knowledge and also confirm with her if she is having any black screen?!

I hold volume up + volume down + power and enter a blank screen but got error as shown in the screenshot below:

QFIL can still connect and workable.

I enter QDLoader mode by adb command line and got this result as shown in the screenshot below:

There are a few more mode with blank screen that QFIL can connect. And your firmware release date is still 2021.04.20 and not changed to the flashed firmware with 2021.08.05_02 release date. That’s why I wonder you flashed in the wrong mode that causes your Hipad Pro bricked. I tried to enter QDLoader mode via fastboot but unfornately Hipad Pro firmware is not implemented this command: fastboot reboot edl or any other possible fastboot commands to access QDLoader mode.

However if you beleive that you are doing it correctly, there are 2 options to fix this:

  1. Wait for the new official firmware from Chuwi that gets your Hipad Pro unbricked.
  2. Return and claim the new one from your seller like gibus did. His newly clamed got unlocked.

Hope you will find the solution for this soon.

1 Like

Super again thank you for all your shared details.

Can I ask you, from where did you get the tutorial?

Maybe we could ask the user if there is any kind of requirements in order to execute all the steps that she mentioned on her tutorial!

Btw…that tutorial is basically to install which firmware? or what exactly does to our tablets?

Thank you and sorry for the silly questions

I wrote to a moderator about the firmware. This is the answer. So is a bad firmware confirmed by them no?

@super @manuelbrunopt @Anathema @gibus

1 Like

The Chinese manual is in the QPST folder. The English manual is created by translating the Chinese manual by Google Translator. 99.99% of the English manual is the same meaning as the Chinese manual. I add some words to clarify the meaning in the English manual.
You can e-mail Wan to ask about more details of the manual.

Can you follow this post to enter QDLoader mode and take screenshots as shown in this post? I’d like to see the com port that connects Hipad Pro to PC. When I tried to enter QDLoader mode by adb command line, the com port connected at Com10. But when I tried to enter QDLoader mode by holding volume down + volume up + power, the com port connected at Com40 with error. I wonder why these com port connections are different when I tried to enter the same QDLoader mode.

@super it gives you error because depending of driver version sometimes it gives an error that is easy fixed just disable mandatory driver signing this is done from the windows startup settings and after that you will see that the yellow warning dissapear because it is related with driver signing.

COM port just depends of your computer, programs and devices connected it doesn’t matter I tell you because I try to flash in 3 differents computers and almost always is different.